Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357271 - eclipse does not start
Summary: eclipse does not start
Keywords:
Status: CLOSED DUPLICATE of bug 1333480
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 24
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-17 14:13 UTC by Jan Kratochvil
Modified: 2016-07-18 14:48 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-18 14:48:21 UTC


Attachments (Terms of Use)
/home/lace/workspace/.metadata/.log (deleted)
2016-07-17 14:13 UTC, Jan Kratochvil
no flags Details
rpm -qa (deleted)
2016-07-17 14:15 UTC, Jan Kratochvil
no flags Details

Description Jan Kratochvil 2016-07-17 14:13:46 UTC
Created attachment 1180777 [details]
/home/lace/workspace/.metadata/.log

Description of problem:
Eclipse fails to start.  I believe it will start on a fresh Fedora 24 x86_64 installation, my installation is an in-place upgrade for many Fedora releases but it still should work I guess.

Version-Release number of selected component (if applicable):
eclipse-platform-4.6.0-0.6.git201605092000.fc24.x86_64
freemarker-2.3.23-2.fc24.noarch

How reproducible:
Always.

Steps to Reproduce:
rm -rf ~/workspace ~/.eclipse;eclipse

Actual results:
It asks for the workspace directory.
An error has occured.  See the log file /home/lace/workspace/.metadata/.log.

Expected results:
Started Eclipse.

Additional info:

Comment 1 Jan Kratochvil 2016-07-17 14:14:20 UTC
rpm -V $(rpm -qa '*eclipse*' freemarker)
has empty output.

Comment 2 Jan Kratochvil 2016-07-17 14:15:01 UTC
Created attachment 1180778 [details]
rpm -qa

Comment 3 Mat Booth 2016-07-18 09:33:15 UTC
Do you have any Eclipse localisation packages installed? Please paste the output of:

rpm -qa | grep eclipse-nls

Comment 4 Jan Kratochvil 2016-07-18 11:50:54 UTC
You could check rpm -qa in my Comment 2 attachment.

Yes, you are right - I had installed:
  eclipse-nls-4.5.0.v20150804081228-3.fc24.noarch
  eclipse-nls-cs-4.5.0.v20150804081228-3.fc24.noarch
Removing them fixed the crash, thanks.

I have tried for example:
  dnf install eclipse-nls-uk
and that one does not crash.

dnf install 'eclipse-nls*'
does crash again.

Comment 5 Mat Booth 2016-07-18 14:48:21 UTC
Great, the fix is already in updates-testing: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e382dece0e

*** This bug has been marked as a duplicate of bug 1333480 ***


Note You need to log in before you can comment on or make changes to this bug.