Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357259 - When reducing the 'OvfUpdateIntervalInMinutes' to 1 there is performance degradation.
Summary: When reducing the 'OvfUpdateIntervalInMinutes' to 1 there is performance degr...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: General
Version: 4.0.2
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: ovirt-4.1.0-beta
: ---
Assignee: Liron Aravot
QA Contact: Eyal Shenitzky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-17 10:09 UTC by Eyal Shenitzky
Modified: 2017-02-08 16:12 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-29 15:15:25 UTC
oVirt Team: Storage
rule-engine: ovirt-4.1+


Attachments (Terms of Use)
Engine and vdsm log (deleted)
2016-07-17 10:09 UTC, Eyal Shenitzky
no flags Details
new VDSM and engine logs (deleted)
2017-01-10 09:35 UTC, Eyal Shenitzky
no flags Details
engine and vdsm logs (deleted)
2017-01-25 07:39 UTC, Eyal Shenitzky
no flags Details

Description Eyal Shenitzky 2016-07-17 10:09:38 UTC
Created attachment 1180725 [details]
Engine and vdsm log

Description of problem:

When reducing the 'OvfUpdateIntervalInMinutes' to 1 there is performance degradation.

For example, in env with 9 storage domains with template that has disk on each one of the storage domains, when creating disk, disks OVF update occurs and the duration of the disk creation extends and fails due to disk creation timeout.

Therefore disks OVF update task should be in a different process and not on the main thread.
  

Version-Release number of selected component (if applicable):
Engine - 4.0.2-0.2.rc1.el7ev

How reproducible:
100%

Steps to Reproduce:

1.Reduce the 'OvfUpdateIntervalInMinutes' to 1
2.Create a new thin copy iscsi disk from template to the VM

Actual results:
Disk creation fails

Expected results:
Disk creation succeed

Additional info:

Comment 2 Eyal Shenitzky 2016-07-24 12:58:03 UTC
Hi Yaniv,

Moving the OVF update Task to different proccess came after consulting with dev-storage, so i guess that the suggestion you mentioned above can work also.
The bottom line is that the Task that responsible for updating the OVF consume 
resources and effects the other Tasks.

The reason that we reduce the OvfUpdateIntervalInMinutes to 1 min is that we will 
be able to test it in our automation.
But because that option is available, we should consider how it will not affect on the performance as mentioned.

Comment 3 Yaniv Kaul 2016-07-24 13:00:39 UTC
(In reply to Eyal Shenitzky from comment #2)

> The reason that we reduce the OvfUpdateIntervalInMinutes to 1 min is that we
> will 
> be able to test it in our automation.
> But because that option is available, we should consider how it will not
> affect on the performance as mentioned.

That's something else - and one I already talked to with someone (Raz?) - what you should do is probably do something early in the tests, then run other tests, then get back to whatever you needed to test (that the OVF is up-to-date for example) rather than lowering the value to unrealistic values.

Comment 4 Liron Aravot 2017-01-08 16:41:23 UTC
Eyal,
The log file you uploaded is broken, please upload a valid file so i'll be able to determine what was the issue in your environment.

Thanks,
Liron

Comment 5 Eyal Shenitzky 2017-01-10 09:35:33 UTC
Created attachment 1239022 [details]
new VDSM and engine logs

I added new logs

Comment 6 Liron Aravot 2017-01-19 17:23:52 UTC
Eyal, the new log file is broken as well.

Thanks,
Liron

Comment 7 Eyal Shenitzky 2017-01-25 07:39:34 UTC
Created attachment 1244175 [details]
engine and vdsm logs

Comment 8 Liron Aravot 2017-01-29 15:15:25 UTC
There's no disk creation in the provided log, opposed to the original scenario.

Eyal - i'm closing it in the meanwhile as the OVF update process shouldn't affect disk creations (I've asked for the logs to determine the cause of failure in your env). Please reopen if relevant.


Note You need to log in before you can comment on or make changes to this bug.