Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357244 - Workrave and Workrave Shell Extension are crashing under Wayland
Summary: Workrave and Workrave Shell Extension are crashing under Wayland
Keywords:
Status: CLOSED DUPLICATE of bug 1384638
Alias: None
Product: Fedora
Classification: Fedora
Component: workrave
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Yaakov Selkowitz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1354272 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-17 07:46 UTC by Noam Cohen
Modified: 2016-11-25 13:42 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-13 18:13:45 UTC


Attachments (Terms of Use)
Journalctl messages related to Workrave documenting the crash (deleted)
2016-07-17 07:46 UTC, Noam Cohen
no flags Details

Description Noam Cohen 2016-07-17 07:46:50 UTC
Created attachment 1180665 [details]
Journalctl messages related to Workrave documenting the crash

Description of problem:
When running a Wayland Gnome session - Workrave crashes on startup.

Version-Release number of selected component (if applicable):
workrave 1.10.15-1.fc24
gnome-session-wayland-session.x86_64 3.20.1-1.fc24


How reproducible:
Happens every time when trying to launch workrave under Wayland


Steps to Reproduce:
1. Login to a Gnome Wayland session
2. Try to run Workrave

Optionally - enable the Workrave Gnome Shell Extension and login to a Gnome Wayland Session - the extension will also crash.

Actual results:
Workrave crahses.


Expected results:
Workrave startup properly.

Additional info:
Attached are the relevant error messages from the jounral log.

Comment 1 Yaakov Selkowitz 2016-07-20 01:56:12 UTC
Workrave has no Wayland backend; until such time that it has one, it simply won't work thereon.

Comment 2 Yaakov Selkowitz 2016-08-29 19:27:14 UTC
*** Bug 1354272 has been marked as a duplicate of this bug. ***

Comment 3 Adam Williamson 2016-10-13 18:05:33 UTC
I don't think the resolution here is correct. Fedora's Workstation Wayland session is supposed to run apps that aren't yet ported to be native Wayland apps just fine; that's what XWayland is for. Almost all apps are still running through XWayland by default, in fact. So this is not an expected outcome.

Comment 4 Adam Williamson 2016-10-13 18:13:45 UTC
OK, I reproduced and filed a crash report with abrt, so marking as a dupe of that.

*** This bug has been marked as a duplicate of bug 1384638 ***


Note You need to log in before you can comment on or make changes to this bug.