Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357243 - Missing language and wave files.
Summary: Missing language and wave files.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: inadyn-mt
Version: 24
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Michael Cronenworth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-17 07:39 UTC by Thomas Mohaupt
Modified: 2016-08-16 22:20 UTC (History)
2 users (show)

Fixed In Version: inadyn-mt-2.28.06-1.fc24 inadyn-mt-2.28.06-1.fc23
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-16 19:24:01 UTC


Attachments (Terms of Use)
set prefix to /usr/share when calling configure (deleted)
2016-07-23 13:10 UTC, Thomas Mohaupt
no flags Details | Diff

Description Thomas Mohaupt 2016-07-17 07:39:02 UTC
Description of problem:
inadyn-mt is unable to open a language file and the default wave file. 

Version-Release number of selected component (if applicable):
Fedora release 24 (Twenty Four) (vagrant box "fedora/24-cloud-base")
inadyn-mt-2.24.49-2.fc24.x86_64

How reproducible:

Steps to Reproduce:
1. vagrant init fedora/24-cloud-base; vagrant up --provider virtualbox
2. vagrant ssh
3. sudo yum install inadyn-mt
4. inadyn -h

Actual results:
[vagrant@localhost ~]$ inadyn -h
Sun Jul 17 07:34:55 2016: W:LANG: Cannot open language file.  Will use english defaults, or default override (--lang_file <path/file_name>...)
Sun Jul 17 07:34:55 2016: W:INADYN: Could not open default wave file, extra/wav/alarm.wav.  Using default, ./alarm.wav...
Sun Jul 17 07:34:55 2016: W:GETCMD: Missing option value at position 3 ('--username')
[ right help content as expected ]
Sun Jul 17 07:34:55 2016: W:MAIN: Main: Error 'RC_CMD_PARSER_INVALID_OPTION_ARGUMENT' (0x51).

Expected results:
Just the help

Additional info:

Comment 1 Thomas Mohaupt 2016-07-23 13:09:07 UTC
The reason is that it searches in subdirs of /usr/inadym-mt/ instead of /usr/share/inadym-mt. 

I was able to fix it in the SRPM package. I set the prefix to /usr/share - then it searches in /usr/share/inadym-mt and is able to load the default files:
/usr/share/inadyn-mt/lang/en.lng
/usr/share/inadyn-mt/extra/servers_additional.cfg
/usr/share/inadyn-mt/extra/wav/alarm.wav

ThoMo

Comment 2 Thomas Mohaupt 2016-07-23 13:10:33 UTC
Created attachment 1183094 [details]
set prefix to /usr/share when calling configure

Patch for SRPM spec file

Comment 3 Fedora Admin XMLRPC Client 2016-07-29 17:28:24 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Fedora Update System 2016-08-05 16:10:08 UTC
inadyn-mt-2.28.06-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cf9db62e78

Comment 5 Fedora Update System 2016-08-05 16:12:41 UTC
inadyn-mt-2.28.06-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3c59bfae33

Comment 6 Fedora Update System 2016-08-09 01:23:17 UTC
inadyn-mt-2.28.06-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3c59bfae33

Comment 7 Fedora Update System 2016-08-09 01:27:17 UTC
inadyn-mt-2.28.06-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cf9db62e78

Comment 8 Fedora Update System 2016-08-16 19:23:53 UTC
inadyn-mt-2.28.06-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2016-08-16 22:20:43 UTC
inadyn-mt-2.28.06-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.