Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357242 - Failed to upgrade ovirt-engine-setup.
Summary: Failed to upgrade ovirt-engine-setup.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Setup.Engine
Version: 4.0.2
Hardware: x86_64
OS: Linux
unspecified
urgent vote
Target Milestone: ---
: ---
Assignee: Sandro Bonazzola
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-17 06:40 UTC by Nikolai Sednev
Modified: 2017-05-11 11:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-18 09:17:23 UTC
oVirt Team: Integration
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
sosreport from engine (deleted)
2016-07-17 06:44 UTC, Nikolai Sednev
no flags Details

Description Nikolai Sednev 2016-07-17 06:40:31 UTC
Description of problem:
Failed to upgrade ovirt-engine-setup.

# engine-setup 
[ INFO  ] Stage: Initializing
[ INFO  ] Stage: Environment setup
          Configuration files: ['/etc/ovirt-engine-setup.conf.d/10-packaging-wsp.conf', '/etc/ovirt-engine-setup.conf.d/10-packaging.conf', '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf']
          Log file: /var/log/ovirt-engine/setup/ovirt-engine-setup-20160717023900-ti3wgc.log
          Version: otopi-1.5.1 (otopi-1.5.1-3.el7ev)
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ INFO  ] Stage: Environment customization
         
          Welcome to the RHEV 4.0 setup/upgrade.
          Please read the RHEV 4.0 install guide
          https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/4.0/html/Installation_Guide/index.html.
          Please refer to the RHEV Upgrade Helper application
          https://access.redhat.com/labs/rhevupgradehelper/ which will guide you in the upgrading process.
          Would you like to proceed? (Yes, No) [Yes]: 
         
          --== PRODUCT OPTIONS ==--
         
         
          --== PACKAGES ==--
         
[ INFO  ] Checking for product updates...
          Setup has found updates for some packages:
          PACKAGE: [updated] ovirt-engine-dashboard-1.0.0-20160623git48c5592.el7ev.x86_64
          PACKAGE: [update] ovirt-engine-dashboard-1.0.0-20160705git3e1e994.el7ev.x86_64
          PACKAGE: [updated] ovirt-engine-dwh-4.0.0-2.el7ev.noarch
          PACKAGE: [update] ovirt-engine-dwh-4.0.1-1.el7ev.noarch
          do you wish to update them now? (Yes, No) [Yes]: 
[ INFO  ] Checking for an update for Setup...
          Setup will not be able to rollback new packages in case of a failure, because the following installed packages were not found in enabled repositories:
         
          ovirt-engine-dashboard-1.0.0-20160623git48c5592.el7ev.x86_64
          ovirt-engine-dwh-4.0.0-2.el7ev.noarch
          Do you want to abort Setup? (Yes, No) [Yes]: no
[ ERROR ] ['ovirt-engine-setup-4.0.2-0.2.rc1.el7ev.noarch'] cannot be found in enabled repositories. Seems like required channels/repositories are not available on the system.
[ ERROR ] Failed to execute stage 'Environment customization': Setup cannot be found in enabled repositories.
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20160717023900-ti3wgc.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20160717023922-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed

Version-Release number of selected component (if applicable):
Engine:
rhevm-spice-client-x86-msi-4.0-2.el7ev.noarch
rhevm-spice-client-x64-msi-4.0-2.el7ev.noarch
rhev-release-4.0.1-2-001.noarch
rhevm-branding-rhev-4.0.0-3.el7ev.noarch
rhevm-setup-plugins-4.0.0.1-1.el7ev.noarch
rhevm-guest-agent-common-1.0.12-2.el7ev.noarch
rhevm-4.0.2-0.2.rc1.el7ev.noarch
rhevm-dependencies-4.0.0-1.el7ev.noarch
rhevm-doc-4.0.0-2.el7ev.noarch
rhev-guest-tools-iso-4.0-2.el7ev.noarch
Linux version 3.10.0-462.el7.x86_64 (mockbuild@x86-034.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-8) (GCC) ) #1 SMP Thu Jul 7 10:15:22 EDT 2016
Linux 3.10.0-462.el7.x86_64 #1 SMP Thu Jul 7 10:15:22 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.3 Beta (Maipo)


How reproducible:
100%

Steps to Reproduce:
1.Upgrade ovirt-engine-setup.
2.
3.

Actual results:
[ ERROR ] Failed to execute stage 'Environment customization': Setup cannot be found in enabled repositories.

Expected results:
Should work without errors.

Additional info:
Sosreport from the engine.

Comment 1 Nikolai Sednev 2016-07-17 06:44:17 UTC
Created attachment 1180664 [details]
sosreport from engine

Comment 2 Yedidyah Bar David 2016-07-17 07:15:39 UTC
It was some problem in CI. Currently bob only has 4.0.1. At some point it had 4.0.2, and you got that. Please clean up and try again. You might do that by forcing downgrade to what's currently on bob.

Comment 3 Nikolai Sednev 2016-07-18 08:53:09 UTC
(In reply to Yedidyah Bar David from comment #2)
> It was some problem in CI. Currently bob only has 4.0.1. At some point it
> had 4.0.2, and you got that. Please clean up and try again. You might do
> that by forcing downgrade to what's currently on bob.

Requires redeployment of HE on clean environment as CI made changes within the repos, will try to redeploy, please consider closing this bug as it was caused by CI changes.

Comment 4 Nikolai Sednev 2017-05-11 11:12:24 UTC
CI related issue.


Note You need to log in before you can comment on or make changes to this bug.