Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357237 - Plots display black window
Summary: Plots display black window
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: octave
Version: 24
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-17 02:55 UTC by Daryll
Modified: 2016-07-23 19:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-23 19:42:00 UTC


Attachments (Terms of Use)

Description Daryll 2016-07-17 02:55:01 UTC
Description of problem:

If you attempt to plot anything in octave you get a black window.


Version-Release number of selected component (if applicable):
4.0.1-6.fc24.x86_64
4.0.3-1.fc24.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Launch octave gui
2. x = -10:0.1:10;
3. plot (x, sin (x));

Actual results:
Plot window appears but is a large black rectangle

Expected results:
A sin wave graph is displayed

Additional info:
Seems to be an incompatibility with gnuplot-5
See https://savannah.gnu.org/bugs/?42838
Potential patch is here http://hg.savannah.gnu.org/hgweb/octave/rev/8990b8c4f00a

Comment 1 Daryll 2016-07-23 19:42:00 UTC
It turns out it was a problem with my graphics driver.


Note You need to log in before you can comment on or make changes to this bug.