Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357204 (jmockit) - Review Request: jmockit - Java toolkit for unit/integration testing [+ dependencies tracker]
Summary: Review Request: jmockit - Java toolkit for unit/integration testing [+ depend...
Keywords:
Status: CLOSED DEFERRED
Alias: jmockit
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: gil cattaneo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: NotReady
Depends On: 1290790 1397307 1442391
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-16 15:46 UTC by Raphael Groner
Modified: 2018-12-04 13:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-22 10:30:13 UTC
puntogil: fedora-review?


Attachments (Terms of Use)
licensecheck.txt (deleted)
2016-07-16 18:14 UTC, gil cattaneo
no flags Details

Description Raphael Groner 2016-07-16 15:46:01 UTC
Spec URL: https://raphgro.fedorapeople.org/review/java/testing/jmockit.spec
SRPM URL: https://raphgro.fedorapeople.org/review/java/testing/jmockit-1.19-1.20150623git3203901.fc24.src.rpm
Description: Java toolkit for unit/integration testing
JMockit is a Java toolkit for developer (unit/integration) testing.
It contains mocking APIs and other tools, supporting both JUnit and
TestNG. The mocking APIs allow all kinds of Java code, without testability
restrictions, to be tested in isolation from selected dependencies.

Fedora Account System Username: raphgro

Test builds: https://copr.fedorainfracloud.org/coprs/raphgro/review/build/388898/

Note: Version 1.19 is the newest version I managed to build in Fedora 24 because of all the changing dependencies. For instance, latest version (1.26) needs JUnit5 what's not yet released nor packaged.

Comment 1 gil cattaneo 2016-07-16 17:46:45 UTC
you must add: Provides:  bundled(objectweb-asm) = 5.0.3 
maybe 5.0.3 is not the correct asm release but for me is not a problem

Comment 2 Raphael Groner 2016-07-16 18:03:46 UTC
(In reply to gil cattaneo from comment #1)
> you must add: Provides:  bundled(objectweb-asm) = 5.0.3 
> maybe 5.0.3 is not the correct asm release but for me is not a problem

Can we unbundle? I based on your spec file. ;)

Comment 3 gil cattaneo 2016-07-16 18:10:24 UTC
(In reply to Raphael Groner from comment #2)
> (In reply to gil cattaneo from comment #1)
> > you must add: Provides:  bundled(objectweb-asm) = 5.0.3 
> > maybe 5.0.3 is not the correct asm release but for me is not a problem
> 
> Can we unbundle? I based on your spec file. ;)

as you want :)

Comment 4 gil cattaneo 2016-07-16 18:10:37 UTC
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[!]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "BSD (3 clause)", "Apache (v2.0)", "GPL (v2)", "Unknown or
     generated". 630 files have unknown license. Detailed output of
     licensecheck in /home/gil/1357204-jmockit/licensecheck.txt

   BSD: ./main/src/mockit/external/asm/*

   GPLv2 with exceptions:
          ./main/src/com/sun/tools/attach/AgentInitializationException.java
          ./main/src/com/sun/tools/attach/AgentLoadException.java
          ./main/src/com/sun/tools/attach/AttachNotSupportedException.java
          ./main/src/com/sun/tools/attach/AttachPermission.java
          ./main/src/com/sun/tools/attach/VirtualMachine.java
          ./main/src/com/sun/tools/attach/VirtualMachineDescriptor.java
          ./main/src/com/sun/tools/attach/spi/AttachProvider.java
          ./main/src/sun/tools/attach/BsdVirtualMachine.java
          ./main/src/sun/tools/attach/HotSpotVirtualMachine.java
          ./main/src/sun/tools/attach/LinuxVirtualMachine.java
          ./main/src/sun/tools/attach/SolarisVirtualMachine.java
          ./main/src/sun/tools/attach/WindowsVirtualMachine.java

          
[x]: License file installed when any subpackage combination is installed.
[!]: Package contains no bundled libraries without FPC exception.

These files are part of objectweb-asm package:
          ./main/src/mockit/external/asm/*
These files are part of JDK:
          ./main/src/com/sun/tools/attach/AgentInitializationException.java
          ./main/src/com/sun/tools/attach/AgentLoadException.java
          ./main/src/com/sun/tools/attach/AttachNotSupportedException.java
          ./main/src/com/sun/tools/attach/AttachPermission.java
          ./main/src/com/sun/tools/attach/VirtualMachine.java
          ./main/src/com/sun/tools/attach/VirtualMachineDescriptor.java
          ./main/src/com/sun/tools/attach/spi/AttachProvider.java
          ./main/src/sun/tools/attach/HotSpotVirtualMachine.java
          ./main/src/sun/tools/attach/LinuxVirtualMachine.java
    
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[?]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 10240 bytes in 1 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

Java:
[x]: Bundled jar/class files should be removed before build
[x]: Packages have proper BuildRequires/Requires on jpackage-utils
     Note: Maven packages do not need to (Build)Require jpackage-utils. It
     is pulled in by maven-local
[x]: Javadoc documentation files are generated and included in -javadoc
     subpackage
[x]: Javadoc subpackages should not have Requires: jpackage-utils
[x]: Javadocs are placed in %{_javadocdir}/%{name} (no -%{version} symlink)

Maven:
[x]: If package contains pom.xml files install it (including metadata) even
     when building with ant
[x]: POM files have correct Maven mapping
[x]: Maven packages should use new style packaging
[x]: Old add_to_maven_depmap macro is not being used
[x]: Packages DO NOT have Requires(post) and Requires(postun) on jpackage-
     utils for %update_maven_depmap macro
[x]: Package DOES NOT use %update_maven_depmap in %post/%postun
[x]: Packages use .mfiles file list instead of %{_datadir}/maven2/poms

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[-]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in jmockit-
     coverage , jmockit-javadoc
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

Java:
[x]: Package uses upstream build method (ant/maven/etc.)
[x]: Packages are noarch unless they use JNI

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: jmockit-1.19-1.20150623git3203901.fc25.noarch.rpm
          jmockit-coverage-1.19-1.20150623git3203901.fc25.noarch.rpm
          jmockit-javadoc-1.19-1.20150623git3203901.fc25.noarch.rpm
          jmockit-1.19-1.20150623git3203901.fc25.src.rpm
jmockit.noarch: W: spelling-error %description -l en_US testability -> test ability, test-ability, incontestability
jmockit.noarch: W: only-non-binary-in-usr-lib
jmockit-coverage.noarch: W: spelling-error %description -l en_US overridable -> irrecoverable
jmockit-coverage.noarch: W: only-non-binary-in-usr-lib
jmockit-coverage.noarch: W: no-documentation
jmockit.src: W: spelling-error %description -l en_US testability -> test ability, test-ability, incontestability
4 packages and 0 specfiles checked; 0 errors, 6 warnings.




Rpmlint (installed packages)
----------------------------
jmockit.noarch: W: spelling-error %description -l en_US testability -> test ability, test-ability, incontestability
jmockit.noarch: W: only-non-binary-in-usr-lib
jmockit-coverage.noarch: W: spelling-error %description -l en_US overridable -> irrecoverable
jmockit-coverage.noarch: W: only-non-binary-in-usr-lib
jmockit-coverage.noarch: W: no-documentation
3 packages and 0 specfiles checked; 0 errors, 5 warnings.



Requires
--------
jmockit (rpmlib, GLIBC filtered):
    java
    java-headless
    javapackages-tools
    mvn(javax.inject:javax.inject)
    mvn(org.apache.geronimo.specs:geronimo-ejb_3.1_spec)

jmockit-javadoc (rpmlib, GLIBC filtered):
    javapackages-tools

jmockit-coverage (rpmlib, GLIBC filtered):
    java-headless
    javapackages-tools



Provides
--------
jmockit:
    jmockit
    mvn(org.jmockit:jmockit)
    mvn(org.jmockit:jmockit:pom:)

jmockit-javadoc:
    jmockit-javadoc

jmockit-coverage:
    jmockit-coverage
    mvn(org.jmockit:jmockit-coverage)
    mvn(org.jmockit:jmockit-coverage:pom:)



Source checksums
----------------
https://raw.githubusercontent.com/jmockit/jmockit.github.io/master/api1x/overview.html :
  CHECKSUM(SHA256) this package     : 9447da9bf7e69c4bdc133b09dbd9784fcd476ffdd821268c784c3e12c9698082
  CHECKSUM(SHA256) upstream package : 9447da9bf7e69c4bdc133b09dbd9784fcd476ffdd821268c784c3e12c9698082
https://raw.githubusercontent.com/jmockit/jmockit.github.io/master/api1x/stylesheet.css :
  CHECKSUM(SHA256) this package     : 1bd7e17fe3d51bcd775fff086f66b19fc97a2f467248f382d8310c6b114c4d5e
  CHECKSUM(SHA256) upstream package : 1bd7e17fe3d51bcd775fff086f66b19fc97a2f467248f382d8310c6b114c4d5e
https://github.com/jmockit/jmockit1/archive/320390106be6b4ae9e602be5cb40c120a565c5b0/jmockit1-320390106be6b4ae9e602be5cb40c120a565c5b0.tar.gz :
  CHECKSUM(SHA256) this package     : 12192d036afb8021384f71a0543006bf586f95e40176ed3d0d2f6cd27c03bc6b
  CHECKSUM(SHA256) upstream package : 12192d036afb8021384f71a0543006bf586f95e40176ed3d0d2f6cd27c03bc6b


Generated by fedora-review 0.6.1 (f03e4e7) last change: 2016-05-02
Command line :/usr/bin/fedora-review -b 1357204 --plugins Java -m fedora-rawhide-i386
Buildroot used: fedora-rawhide-i386
Active plugins: Generic, Shell-api, Java
Disabled plugins: C/C++, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6

Comment 5 gil cattaneo 2016-07-16 18:12:54 UTC
Issues:

[!]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "BSD (3 clause)", "Apache (v2.0)", "GPL (v2)", "Unknown or
     generated". 630 files have unknown license. Detailed output of
     licensecheck in /home/gil/1357204-jmockit/licensecheck.txt

   BSD: ./main/src/mockit/external/asm/*

   GPLv2 with exceptions:
          ./main/src/com/sun/tools/attach/AgentInitializationException.java
          ./main/src/com/sun/tools/attach/AgentLoadException.java
          ./main/src/com/sun/tools/attach/AttachNotSupportedException.java
          ./main/src/com/sun/tools/attach/AttachPermission.java
          ./main/src/com/sun/tools/attach/VirtualMachine.java
          ./main/src/com/sun/tools/attach/VirtualMachineDescriptor.java
          ./main/src/com/sun/tools/attach/spi/AttachProvider.java
          ./main/src/sun/tools/attach/BsdVirtualMachine.java
          ./main/src/sun/tools/attach/HotSpotVirtualMachine.java
          ./main/src/sun/tools/attach/LinuxVirtualMachine.java
          ./main/src/sun/tools/attach/SolarisVirtualMachine.java
          ./main/src/sun/tools/attach/WindowsVirtualMachine.java

          

[!]: Package contains no bundled libraries without FPC exception.

See Comment#1

These files are part of objectweb-asm package:
          ./main/src/mockit/external/asm/*
These files are part of JDK:
          ./main/src/com/sun/tools/attach/AgentInitializationException.java
          ./main/src/com/sun/tools/attach/AgentLoadException.java
          ./main/src/com/sun/tools/attach/AttachNotSupportedException.java
          ./main/src/com/sun/tools/attach/AttachPermission.java
          ./main/src/com/sun/tools/attach/VirtualMachine.java
          ./main/src/com/sun/tools/attach/VirtualMachineDescriptor.java
          ./main/src/com/sun/tools/attach/spi/AttachProvider.java
          ./main/src/sun/tools/attach/HotSpotVirtualMachine.java
          ./main/src/sun/tools/attach/LinuxVirtualMachine.java

Comment 6 gil cattaneo 2016-07-16 18:14:33 UTC
Created attachment 1180493 [details]
licensecheck.txt

Comment 7 gil cattaneo 2016-07-16 18:17:08 UTC
Complete list othe JDK files under GPLv2 with exceptions license:
./main/src/com/sun/tools/attach/AgentInitializationException.java
./main/src/com/sun/tools/attach/AgentLoadException.java
./main/src/com/sun/tools/attach/AttachNotSupportedException.java
./main/src/com/sun/tools/attach/AttachPermission.java
./main/src/com/sun/tools/attach/VirtualMachine.java
./main/src/com/sun/tools/attach/VirtualMachineDescriptor.java
./main/src/com/sun/tools/attach/spi/AttachProvider.java
./main/src/sun/tools/attach/BsdVirtualMachine.java
./main/src/sun/tools/attach/HotSpotVirtualMachine.java
./main/src/sun/tools/attach/LinuxVirtualMachine.java
./main/src/sun/tools/attach/SolarisVirtualMachine.java
./main/src/sun/tools/attach/WindowsVirtualMachine.java

Comment 8 Raphael Groner 2016-07-17 13:50:47 UTC
We should make the tests work, and see if we can use the latest version of jmockit with JUnit5.

Comment 9 Raphael Groner 2016-12-09 20:48:18 UTC
Gil,
how far is upstream development with JUnit5?

Comment 10 gil cattaneo 2016-12-10 03:08:49 UTC
(In reply to Raphael Groner from comment #9)
> Gil,
> how far is upstream development with JUnit5?

Have no time for J5 now, is available a new milestone (r5.0.0-M3)
but we could try to import only after
https://bugzilla.redhat.com/show_bug.cgi?id=1397307
will be solved.
This is a list of some not available dependencies:
de.schauderhaft.degraph:degraph-check:0.1.4
This and a list of dependencies what should be updated:
net.sf.jopt-simple:jopt-simple:5.0.3
org.assertj:assertj-core:3.6.0
org.mockito:mockito-core:2.2.22
org.spockframework:spock-core:1.0-groovy-2.4 https://bugzilla.redhat.com/show_bug.cgi?id=1290790

Comment 11 Raphael Groner 2016-12-11 09:29:00 UTC
Okay, let's wait till those things got sorted out.

Comment 12 Raphael Groner 2017-09-22 10:30:13 UTC
Very old, might be dead and I completely lost interest.


Note You need to log in before you can comment on or make changes to this bug.