Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357157 - Upgrading the Satellite server removes the Hypervisor profiles
Summary: Upgrading the Satellite server removes the Hypervisor profiles
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Upgrades
Version: 6.2.0
Hardware: All
OS: Linux
high
high vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1357936
TreeView+ depends on / blocked
 
Reported: 2016-07-15 22:38 UTC by Deepannagaraj Nagarathinam
Modified: 2019-04-01 20:27 UTC (History)
5 users (show)

Fixed In Version: rubygem-katello-3.0.0.65-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1357936 (view as bug list)
Environment:
Last Closed: 2016-07-27 11:35:18 UTC


Attachments (Terms of Use)
hypervisor profiles post upgrade are visible under content-hosts page (deleted)
2016-07-21 11:58 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 15726 None None None 2016-07-18 20:00:19 UTC

Description Deepannagaraj Nagarathinam 2016-07-15 22:38:58 UTC
Description of problem:

While upgrading the Satellite server from 6.1 to 6.2 (Beta), it removes all the Hypervisor profiles from the Satellite server.

Version-Release number of selected component (if applicable):

- Satellite 6.2 Beta

How reproducible:

- Always

Steps to Reproduce:

1. Install a Satellite 6.1 Server.

2. Install and configure virt-who (make sure that hypervisor profiles are available).

3. Upgrade the Satellite server to 6.2.

Actual results:

Upgrade process removes the Hypervisor profiles from the Satellite server.

Expected results:

Satellite server should keep the profiles. 

Additional info:

- As the hypervisor profiles are removed the derived SKU is also removed.

- It causes the client to use the Temporary subscription.

- And customer has to attach the subscriptions to the Hypervisor profiles again.

While running the pre_upgrade check it returns the warning,

~~~~~~
# foreman-rake katello:preupgrade_content_host_check
Calculating Host changes on upgrade.  This may take a few minutes.

Summary:
Content hosts to be preserved: 2
Content hosts to be deleted: 1
Details on Content Hosts planned for deletion saved to /tmp/pre-upgrade-1468612101.csv
You may want to manually resolve some of the conflicts and duplicate Content Hosts.
Upon upgrade those found for deletion will be removed permanently.

# cat /tmp/pre-upgrade-1468612101.csv 
uuid, name, hostname, last_checkin, causes for deletion
a4b49ec8-bb33-45d6-aa03-4620e77b9fc1,dca47d81-53d8-11cb-bbeb-b4c1c02ffba4,,2016-07-11T19:57:49.450+0000,Missing hostname information.
~~~~~~

Comment 2 Justin Sherrill 2016-07-18 19:10:08 UTC
Connecting redmine issue http://projects.theforeman.org/issues/15726 from this bug

Comment 3 Bryan Kearney 2016-07-18 22:00:23 UTC
Upstream bug component is Upgrades

Comment 4 Brad Buckingham 2016-07-19 13:11:43 UTC
Moving to ASSIGNED, since there is an upstream PR

Comment 5 Sachin Ghai 2016-07-21 11:57:24 UTC
Verified with upgrade from at6.1.9 -> sat6.2 GA snap21


I can see hypervisor profiles post-upgrade. Please see the attached screenshot.

Comment 6 Sachin Ghai 2016-07-21 11:58:13 UTC
Created attachment 1182447 [details]
hypervisor profiles post upgrade are visible under content-hosts page

Comment 7 Bryan Kearney 2016-07-27 11:35:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.