Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357126 - tcsh: Quoted backslashes gets repeated when taken from history
Summary: tcsh: Quoted backslashes gets repeated when taken from history
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tcsh
Version: 6.8
Hardware: All
OS: Linux
urgent
medium
Target Milestone: rc
: ---
Assignee: David Kaspar [Dee'Kej]
QA Contact: Iveta Wiedermann
Lenka Kimlickova
URL:
Whiteboard:
Depends On: 1334751
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-15 20:11 UTC by Marcel Kolaja
Modified: 2016-12-12 11:27 UTC (History)
11 users (show)

Fixed In Version: tcsh-6.17-35.el6_8.1
Doc Type: Bug Fix
Doc Text:
This update fixes several regressions in the tcsh command language interpreter: * When browsing command history using the <Ctrl+P> or <UpArrow> keys, backslashes are now shown correctly * A backslash now correctly escapes user-defined aliases; this fixes git-completion * The output of the "time" built-in command is now correctly captured when used with the "setenv" built-in command
Clone Of: 1334751
Environment:
Last Closed: 2016-08-23 18:39:03 UTC
dkaspar: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2593261 None None None 2016-08-31 06:29:31 UTC
Red Hat Product Errata RHBA-2016:1666 normal SHIPPED_LIVE tcsh bug fix update 2016-08-23 22:35:08 UTC

Description Marcel Kolaja 2016-07-15 20:11:17 UTC
This bug has been copied from bug #1334751 and has been proposed
to be backported to 6.8 z-stream (EUS).

Comment 10 errata-xmlrpc 2016-08-23 18:39:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1666.html


Note You need to log in before you can comment on or make changes to this bug.