Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357106 - libgfapi: Reduce memcpy in glfs read
Summary: libgfapi: Reduce memcpy in glfs read
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sachin Pandit
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-15 18:54 UTC by Sachin Pandit
Modified: 2018-08-29 03:37 UTC (History)
1 user (show)

Fixed In Version: glusterfs-4.1.3 (or later)
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-29 03:37:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sachin Pandit 2016-07-15 18:54:30 UTC
New implementation to improve the performance of glfs read by reducing the memcpy in read and write code flow.

Comment 1 Vijay Bellur 2016-07-15 19:00:07 UTC
REVIEW: http://review.gluster.org/14932 (libgfapi: Introducing zero copy read for libgfapi.) posted (#1) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 2 Worker Ant 2016-08-22 14:28:56 UTC
REVIEW: http://review.gluster.org/15236 (libgfapi: Introducing zero copy read for libgfapi) posted (#1) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)

Comment 3 Worker Ant 2016-09-08 06:45:59 UTC
REVIEW: http://review.gluster.org/15236 (libgfapi: Introducing zero copy read for libgfapi) posted (#2) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)

Comment 4 Worker Ant 2016-09-16 06:50:12 UTC
REVIEW: http://review.gluster.org/15236 (libgfapi: Introducing zero copy read for libgfapi) posted (#3) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)

Comment 5 Worker Ant 2016-09-16 12:38:39 UTC
REVIEW: http://review.gluster.org/15236 (libgfapi: Introducing zero copy read for libgfapi) posted (#4) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)

Comment 6 Amar Tumballi 2018-08-29 03:37:10 UTC
This update is done in bulk based on the state of the patch and the time since last activity. If the issue is still seen, please reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.