Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357100 - Adding report has duplicate entries in the 'Base your report on' field
Summary: Adding report has duplicate entries in the 'Base your report on' field
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting
Version: 5.6.0
Hardware: All
OS: All
unspecified
unspecified
Target Milestone: GA
: 5.7.0
Assignee: Šimon Lukašík
QA Contact: Jiri Stefanisin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-15 17:59 UTC by Jon Jozwiak
Modified: 2017-03-17 08:05 UTC (History)
5 users (show)

Fixed In Version: 5.7.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-04 12:57:44 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0012 normal SHIPPED_LIVE CFME 5.7.0 bug fixes and enhancement update 2017-01-04 17:50:36 UTC

Description Jon Jozwiak 2016-07-15 17:59:38 UTC
Description of problem:
When creating a new report you have to select an option in the 'Base the report on' drop down.  There are duplicate entries in the drop down that populate different fields.  There are 2 options called 'Images' and 3 options called 'Services'.  If these are specific to something, the title of the option in the drop down should be updated to reflect what they provide.  

Version-Release number of selected component (if applicable):
cfme 5.6 GA

How reproducible:
Always

Steps to Reproduce:
1. Log in to CloudForms UI 
2. Go to Cloud Intel -> Reports -> Reports accordion -> Configuration -> Add a New Report
3. Click on the 'Base your Report on' drop down and scroll through the options

Actual results:
You will find 2 Images options and 3 Services options.  Depending on which option you select you get different results populated in available fields

Expected results:
There should not be duplicate titles in the drop down.  If the 2 images options provide different detail, the drop down titles should be named specific to what they provide

Additional info:

Comment 3 CFME Bot 2016-07-20 12:01:00 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/89c828d8542ef488af83a3cced401f440df038d0

commit 89c828d8542ef488af83a3cced401f440df038d0
Author:     Šimon Lukašík <isimluk@fedoraproject.org>
AuthorDate: Wed Jul 20 10:18:34 2016 +0200
Commit:     Šimon Lukašík <isimluk@fedoraproject.org>
CommitDate: Wed Jul 20 10:19:23 2016 +0200

    Remove duplicate item from reportable models table
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1357100

 app/models/miq_expression.rb | 1 -
 1 file changed, 1 deletion(-)

Comment 4 Šimon Lukašík 2016-07-20 12:56:15 UTC
Hello CFME Bot, please be advised, there are two PRs to this bug
  https://github.com/ManageIQ/manageiq/pull/9886
  https://github.com/ManageIQ/manageiq/pull/9934

Comment 7 errata-xmlrpc 2017-01-04 12:57:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0012.html


Note You need to log in before you can comment on or make changes to this bug.