Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357056 - rubygem-coffee-rails: FTBFS
Summary: rubygem-coffee-rails: FTBFS
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rubygem-coffee-rails
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jun Aruga
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-15 15:19 UTC by Jun Aruga
Modified: 2016-07-19 11:55 UTC (History)
1 user (show)

Fixed In Version: rubygem-coffee-rails-4.2.1-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-19 11:55:16 UTC


Attachments (Terms of Use)
Fix FTBFS, update to 4.2.1. (deleted)
2016-07-18 14:36 UTC, Jun Aruga
no flags Details | Diff

Description Jun Aruga 2016-07-15 15:19:49 UTC
Description of problem:
FTBFS(Fails to build from source) because of retired rubygem-therubyracer.

Version-Release number of selected component (if applicable):
rubygem-coffee-rails-4.1.0-3.fc25

How reproducible:


Steps to Reproduce:
1. $ mock -r fedora-rawhide-x86_64 rubygem-coffee-rails-4.1.0-3.fc25.src.rpm
2.
3.

Actual results:
The test is failed with the message,
No matching package to install: 'rubygem(therubyracer)'
Not all dependencies satisfied
Error: Some packages could not be found.


Expected results:
The test is succeeded.

Comment 1 Jun Aruga 2016-07-15 15:20:06 UTC
I will fix this!

Comment 2 Jun Aruga 2016-07-18 14:36:50 UTC
Created attachment 1181127 [details]
Fix FTBFS, update to 4.2.1.

I fixed FTBFS, and updated to 4.2.1 (latest version).

# highlight

As the test files have been removed from the gem file, I added it manually.
Could you check my patch?

Thanks.

Comment 3 Jun Aruga 2016-07-18 15:17:17 UTC
The dependency is ok.

Comment 4 Vít Ondruch 2016-07-19 05:34:40 UTC
LGTM. I approved your ACL in pkgdb, please continue with build. Thx.

Comment 5 Jun Aruga 2016-07-19 10:00:22 UTC
I pushed the my patch to rawhide with the build.
Koji (fedpkg build): http://koji.fedoraproject.org/koji/taskinfo?taskID=14942017


Note You need to log in before you can comment on or make changes to this bug.