Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357034 - fedmsg-notify-daemon errors with a python stack trace. ImportError: cannot import name get_reported_bugs
Summary: fedmsg-notify-daemon errors with a python stack trace. ImportError: cannot im...
Keywords:
Status: CLOSED DUPLICATE of bug 1246859
Alias: None
Product: Fedora
Classification: Fedora
Component: fedmsg-notify
Version: 24
Hardware: noarch
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Fedora Infrastructure SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-15 14:38 UTC by Jonathan Billings
Modified: 2016-09-25 19:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-25 19:06:29 UTC


Attachments (Terms of Use)

Description Jonathan Billings 2016-07-15 14:38:25 UTC
Description of problem:
After installing the 'fedmsg-notify' package, fedmsg-notify-config and fedmsg-notify-daemon both error out with a python stack trace instead of running.


Version-Release number of selected component (if applicable):
fedmsg-notify-0.5.5-4.fc24.noarch
fedmsg-0.17.2-1.fc24.noarch
fedmsg-base-0.17.2-1.fc24.noarch

How reproducible:
Every time

Steps to Reproduce:
1. dnf -y install fedmsg-notify
2. fedmsg-notify-daemon

Actual results:

$ fedmsg-notify-config
/usr/lib/python2.7/site-packages/fedmsg_notify/gui.py:25: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, Gio
Traceback (most recent call last):
  File "/usr/bin/fedmsg-notify-config", line 9, in <module>
    load_entry_point('fedmsg-notify==0.5.5', 'console_scripts', 'fedmsg-notify-config')()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 547, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2720, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2380, in load
    return self.resolve()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2386, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/usr/lib/python2.7/site-packages/fedmsg_notify/gui.py", line 27, in <module>
    from .filters import filters, get_enabled_filters
  File "/usr/lib/python2.7/site-packages/fedmsg_notify/filters.py", line 24, in <module>
    from .distro_specific import (get_installed_packages,
ImportError: cannot import name get_reported_bugs

When I run fedmsg-notify-daemon:

$ fedmsg-notify-daemon 
/usr/lib64/python2.7/site-packages/twisted/internet/gireactor.py:115: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk as _gtk
No handlers could be found for logger "moksha.hub"
/usr/lib/python2.7/site-packages/fedmsg_notify/daemon.py:43: PyGIWarning: Notify was imported without specifying a version first. Use gi.require_version('Notify', '0.7') before import to ensure that the right version gets loaded.
  from gi.repository import Notify, Gio, GLib
Traceback (most recent call last):
  File "/usr/bin/fedmsg-notify-daemon", line 9, in <module>
    load_entry_point('fedmsg-notify==0.5.5', 'console_scripts', 'fedmsg-notify-daemon')()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 547, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2720, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2380, in load
    return self.resolve()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2386, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/usr/lib/python2.7/site-packages/fedmsg_notify/daemon.py", line 45, in <module>
    from filters import get_enabled_filters, filters as all_filters
  File "/usr/lib/python2.7/site-packages/fedmsg_notify/filters.py", line 24, in <module>
    from .distro_specific import (get_installed_packages,
ImportError: cannot import name get_reported_bugs



Expected results:
Daemon runs.

Additional info:
I see there has been some work upstream at <https://github.com/fedora-infra/fedmsg-notify/>, perhaps it just needs to be updated?

Comment 2 Kevin Fenzi 2016-09-25 19:06:29 UTC

*** This bug has been marked as a duplicate of bug 1246859 ***


Note You need to log in before you can comment on or make changes to this bug.