Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357002 - Boxes closes on VM start or trying to open an already running VM
Summary: Boxes closes on VM start or trying to open an already running VM
Keywords:
Status: CLOSED DUPLICATE of bug 1357200
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-15 13:05 UTC by Oliver Gutiérrez
Modified: 2016-07-20 12:45 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-20 11:04:01 UTC


Attachments (Terms of Use)

Description Oliver Gutiérrez 2016-07-15 13:05:31 UTC
Description of problem:

Gnome boxes closes unexpectedly when it is about to show VM screen

Version-Release number of selected component (if applicable): 

gnome-boxes.x86_64                     3.20.2-4.fc24               @updates-libvirt.x86_64                         1.3.3.1-4.fc24              @updates   

How reproducible: Always


Steps to Reproduce:
1.Open gnome-boxes
2.Start vm
3.Gnome boxes closes

or

1.Open Gnome boxes
2.Open an already running VM (The one you tried to start, now is running)
3.Gnome boxes closes

Actual results:

Gnome boxes closes unexpectedly

Expected results:

Show VM screen


Additional info:

journalctl:

jul 15 13:54:29 rigel virtlogd[3091]: libvirt version: 1.3.3.1, package: 4.fc24 (Fedora Project, 2016-06-23-20:52:51, buildvm-27.phx2.fedoraproject.org)
jul 15 13:54:30 rigel virtlogd[3091]: hostname: rigel
jul 15 13:54:30 rigel virtlogd[3091]: End of file while reading data: Input/output error
jul 15 13:54:30 rigel audit[3008]: ANOM_ABEND auid=4294967295 uid=1000 gid=1000 ses=4294967295 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=3008 comm="gnome-boxes" exe="/usr/bin/gnome-boxes" sig=6
jul 15 13:54:30 rigel abrt-hook-ccpp[3138]: Process 3008 (gnome-boxes) of user 1000 killed by SIGABRT - dumping core
jul 15 13:54:30 rigel kernel: kvm: zapping shadow pages for mmio generation wraparound
jul 15 13:54:30 rigel kernel: kvm: zapping shadow pages for mmio generation wraparound
jul 15 13:54:30 rigel abrt-hook-ccpp[3138]: /var/spool/abrt is 9625855874 bytes (more than 1279MiB), deleting 'ccpp-2016-07-15-13:48:59-6102'
jul 15 13:54:30 rigel libvirtd[3030]: End of file while reading data: Input/output error
jul 15 13:54:30 rigel libvirtd[1534]: libvirt version: 1.3.3.1, package: 4.fc24 (Fedora Project, 2016-06-23-20:52:51, buildvm-27.phx2.fedoraproject.org)
jul 15 13:54:30 rigel libvirtd[1534]: hostname: rigel
jul 15 13:54:30 rigel libvirtd[1534]: End of file while reading data: Input/output error

Comment 1 Oliver Gutiérrez 2016-07-18 09:17:25 UTC
It seems the problem is happening with virt-manager too, so I think the underlying problem is in libvirt itself.

jul 18 10:11:22 rigel virtlogd[5568]: End of file while reading data: Input/output error
jul 18 10:11:23 rigel audit[7160]: ANOM_ABEND auid=1000 uid=1000 gid=1000 ses=1 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=7160 comm="virt-manager" exe="/usr/bin/python2.7" sig=6
jul 18 10:11:23 rigel abrt-hook-ccpp[7332]: Process 7160 (python2.7) of user 1000 killed by SIGABRT - dumping core

Moving it to Libvirt

Comment 2 Cole Robinson 2016-07-18 13:21:56 UTC
Can you get the backtrace or report the bug with gnome-abrt or similar? Looks like it's crashing and abrt is catching it. Might be libvirt or spice-gtk

Comment 3 Oliver Gutiérrez 2016-07-20 09:16:29 UTC
This is the output I get from gnome-abrt. Any other way to give the requested info?

--- Running report_uReport ---
('report_uReport' completed successfully)

--- Running analyze_CCpp ---
Ok to upload core dump? (It may contain sensitive data). If your answer is 'No', a stack trace will be generated locally. (It may download a huge amount of data). 'YES'
Querying server settings
Preparing an archive to upload
Uploading 6,0 MiB
Upload successful
Retrace job started
Analyzing crash data
Preparing environment for backtrace generation
.......
Cleaning environment after backtrace generation
Retrace job finished successfully
Looking for similar problems in bugzilla

Reporting disabled bacause the backtrace is unusable.

Comment 4 Oliver Gutiérrez 2016-07-20 09:17:34 UTC
Maybe this is the info you need:

https://retrace.fedoraproject.org/faf/reports/1216818/

Comment 5 Christophe Fergeau 2016-07-20 09:32:15 UTC
Nasty, it seems to be dying within ffmpeg through gstreamer.
Is gst-inspect-1.0 running successfully?
Do you still get the crash if you remove gstreamer1-libav?

Comment 6 Oliver Gutiérrez 2016-07-20 11:02:43 UTC
Ok. Removing gstreamer1-libav it works flawlessly.

Taking a look to my packages, it seems that gstreamer-libav package comes from non oficial repo (rpmfusion), so the problem is probably there.

Comment 7 Cole Robinson 2016-07-20 12:44:43 UTC
Note it seems someone else hit the same issue, that was fixed by ffmpeg reinstall, so something weird with gstreamer maybe:

https://bugzilla.redhat.com/show_bug.cgi?id=1358178

Comment 8 Cole Robinson 2016-07-20 12:45:47 UTC

*** This bug has been marked as a duplicate of bug 1357200 ***


Note You need to log in before you can comment on or make changes to this bug.