Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356996 - Typo in log message - exteral instead of external
Summary: Typo in log message - exteral instead of external
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
low
medium vote
Target Milestone: ovirt-4.1.0-alpha
: 4.1.0.2
Assignee: Sharon Gratch
QA Contact: sefi litmanovich
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-15 13:00 UTC by Yaniv Kaul
Modified: 2017-07-14 03:50 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-02-01 14:36:44 UTC
oVirt Team: Virt
rule-engine: ovirt-4.1+
rule-engine: planning_ack+
rule-engine: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 60968 master MERGED core: fix a typo in log message for export/import 2016-07-19 11:32:51 UTC

Description Yaniv Kaul 2016-07-15 13:00:39 UTC
Description of problem:
As pointed by an oVirt user, see https://github.com/oVirt/ovirt-engine/blob/2f09e19c195d9129d8ebe5072109b8f0051444ee/backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/ConvertVmCallback.java#L41 :

log.info("Conversion of VM from exteral enironment failed: {}", jobInfo.getDescription());

Should be:
log.info("Conversion of VM from external environment failed: {}", jobInfo.getDescription());

Version-Release number of selected component (if applicable):
master.

Comment 4 Sandro Bonazzola 2016-12-12 13:55:46 UTC
The fix for this issue should be included in oVirt 4.1.0 beta 1 released on December 1st. If not included please move back to modified.

Comment 5 sefi litmanovich 2016-12-20 13:55:09 UTC
Cant' verify this fix in real case scenario due to https://bugzilla.redhat.com/show_bug.cgi?id=1406304.
But this is a typo fix, so.. Please consider if you want to wait until I can invoke v2v import and see the error msg in practice, or we can just move on and verify it.

Comment 6 Sharon Gratch 2016-12-20 14:07:49 UTC
(In reply to sefi litmanovich from comment #5)
> Cant' verify this fix in real case scenario due to
> https://bugzilla.redhat.com/show_bug.cgi?id=1406304.
> But this is a typo fix, so.. Please consider if you want to wait until I can
> invoke v2v import and see the error msg in practice, or we can just move on
> and verify it.

I think you can move on and verify it without waiting since it's really only a typo fix and also since I reproduced it sometimes after the fix and verify the fixed error message.

Comment 7 sefi litmanovich 2016-12-22 09:46:03 UTC
Verified with Version: 4.1.0-0.2.master.20161218144454.gitbaa2853.el7.centos


Note You need to log in before you can comment on or make changes to this bug.