Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356930 - [RFE]The help content of nodectl sub-commands only displays "-h, --help" instruction
Summary: [RFE]The help content of nodectl sub-commands only displays "-h, --help" inst...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: ovirt-node
Classification: oVirt
Component: RFEs
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ---
: ---
Assignee: Fabian Deutsch
QA Contact: Ying Cui
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-15 09:56 UTC by Wei Wang
Modified: 2016-07-15 10:50 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-15 10:50:21 UTC
oVirt Team: Node
rule-engine: planning_ack?
rule-engine: devel_ack?
cshao: testing_ack+


Attachments (Terms of Use)

Description Wei Wang 2016-07-15 09:56:32 UTC
Description of problem:
The help context of nodectl sub-commands only displays "-h, --help" instruction

Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.0-201607013.0.x86_64
imgbased-0.7.2-0.1.el7ev.noarch
cockpit-0.108-1.el7.x86_64

How reproducible:
100%


Steps to Reproduce:
1. Install redhat-virtualization-host-4.0-20160713.0.x86_64 iso
2. Login cockpit website hostIP:9090 with root account
3. Select "Terminal" page
4. Input nodectl check/info -h/--help
5. Check the result


Actual results:
The help context of nodectl sub-commands only displays "-h, --help" instruction
[root@dhcp-11-209 var]# nodectl check --help
usage: __main__.py check [-h]

optional arguments:
    -h, --help show this help message and exit


Expected results:
The help context should contain the instruction of "nodectl check/info", especially the description for sub-command help should have.


Additional info:
1. imgbase check has the same issue
2. refer to some similar command, e.g: virsh vol-clone -h

Comment 1 Wei Wang 2016-07-15 10:50:21 UTC
Since the command nodectl check/info -h/--help has not sub-arguments, so the help content is acceptable. Change the status to CLOSED.


Note You need to log in before you can comment on or make changes to this bug.