Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356928 - Command line installation of yum missing signature for userspace-rcu-0.7.9-2.el7rhgs.x86_64.rpm
Summary: Command line installation of yum missing signature for userspace-rcu-0.7.9-2....
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Documentation
Version: 2.0
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: 2.0
Assignee: ceph-docs@redhat.com
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-15 09:51 UTC by Taco Scargo
Modified: 2016-07-25 13:09 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-19 16:52:27 UTC


Attachments (Terms of Use)

Description Taco Scargo 2016-07-15 09:51:44 UTC
Description of problem:
When installing mon packages using command line options, installation fails

Version-Release number of selected component (if applicable):
2.0 beta 2

How reproducible:
always

Steps to Reproduce:
1. install rhel
2. provision ceph-mon repo
3. yum install ceph-mon

Actual results:
warning: /var/cache/yum/x86_64/7Server/partners.redhat.com_d142f895b78439723be05131f7bda445_Beta2_MON_x86_64_os_/packages/userspace-rcu-0.7.9-2.el7rhgs.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID f21541eb: NOKEY


Public key for userspace-rcu-0.7.9-2.el7rhgs.x86_64.rpm is not installed

Expected results:
installs successfully 


Additional info: looks like a rhgs (gluster) packge

Comment 2 Alfredo Deza 2016-07-15 11:45:33 UTC
For the BETA version you are required to import the key directly:

    sudo rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta

Not sure if you are following a guide, it should point that out.

Comment 3 Taco Scargo 2016-07-15 11:49:04 UTC
I am following the beta deployment guide which does not contain this instruction.
Also the only RPM complaining is an (apparent) Gluster RPM, which I am wondering why it is required for Ceph.

Comment 4 Alfredo Deza 2016-07-15 11:54:14 UTC
If the guide you are following (link please?) does not mention the need to import the key, then this is a doc bug. 

I also don't know why it warrants that package.

Again, a link to the actual guide you are following would be good so that we can route this ticket to the right component (this doesn't look related to the Installer)

Comment 5 Ken Dreyer (Red Hat) 2016-07-15 13:34:34 UTC
We're cross-shipping userspace-rcu from the RH Gluster Storage product so that we don't have to go through the work of re-building it ourselves.

Please import the beta key and retry. If it works, then this is a doc bug.

Comment 6 Ken Dreyer (Red Hat) 2016-07-15 23:18:18 UTC
Not sure if this is worth editing the Beta 2 docs or just closing this.


Note You need to log in before you can comment on or make changes to this bug.