Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356921 - iptables auto-configuration doesn't add ports for glusterfs
Summary: iptables auto-configuration doesn't add ports for glusterfs
Keywords:
Status: CLOSED DUPLICATE of bug 1288979
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Network
Version: 2.0.0.1
Hardware: x86_64
OS: Linux
unspecified
unspecified vote
Target Milestone: ovirt-4.1.0-beta
: ---
Assignee: Sahina Bose
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-15 09:34 UTC by Wee Sritippho
Modified: 2017-05-11 09:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-22 06:28:42 UTC
oVirt Team: Gluster
sabose: ovirt-4.1?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
answer file on 1st host (deleted)
2016-07-15 09:34 UTC, Wee Sritippho
no flags Details
oVirt engine setup log (deleted)
2016-08-01 09:06 UTC, Wee Sritippho
no flags Details
deploy log on 1st host (deleted)
2016-08-01 09:10 UTC, Wee Sritippho
no flags Details
deploy log on 2nd host (deleted)
2016-08-01 09:11 UTC, Wee Sritippho
no flags Details
deploy log on 3rd host (deleted)
2016-08-01 09:12 UTC, Wee Sritippho
no flags Details

Description Wee Sritippho 2016-07-15 09:34:13 UTC
Created attachment 1180083 [details]
answer file on 1st host

Description of problem:
When deploying hyper converged hosted-engine environments, if we allow the setup to configure iptables for us, it would allow only ovirt/vdsm ports but not glusterfs ports such as TCP/24007.

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-2.0.0.2-1.el7.centos.noarch
vdsm-4.18.4.1-0.el7.centos.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install ovirt repo
2. Install and configure glusterfs on 3 hosts (which we will also use for hosted-engine installation)
3. 'hosted-engine --deploy' in 1st host
4. When asked about iptables auto-configuration, accept the default vaule (Yes)
5. Try to deploy another HE hosts on the same data domain

Actual results:
Fail to deploy another HE hosts because they couldn't access gluster brick(s) in 1st host, so the volume become read-only.

Expected results:
If ovirt-hosted-engine-setup detects that setup is hyper converged, also add gluster ports to iptables

Additional info:

Comment 1 Yaniv Lavi 2016-07-21 08:13:18 UTC
Can you please attach logs?

Comment 2 Wee Sritippho 2016-07-21 09:29:26 UTC
Yes, which logs would you like. I'll fetch them when I'm able to access the machines.

Comment 3 Sandro Bonazzola 2016-08-01 08:05:57 UTC
Moving back to Gluster.
This looks like a hyperconverged specific issue since it can't be reproduced on non HC setup.
Can you please attach ovirt-hosted-engine-setup and ovirt-host-deploy logs?
Sahina, if a port is missing probably the engine DB should be changed for including the additional port required by HC

Comment 4 Wee Sritippho 2016-08-01 09:06:57 UTC
Created attachment 1186305 [details]
oVirt engine setup log

Comment 5 Wee Sritippho 2016-08-01 09:10:42 UTC
Created attachment 1186306 [details]
deploy log on 1st host

Comment 6 Wee Sritippho 2016-08-01 09:11:25 UTC
Created attachment 1186308 [details]
deploy log on 2nd host

Comment 7 Wee Sritippho 2016-08-01 09:12:15 UTC
Created attachment 1186309 [details]
deploy log on 3rd host

Comment 8 Sahina Bose 2016-12-22 06:28:42 UTC

*** This bug has been marked as a duplicate of bug 1288979 ***


Note You need to log in before you can comment on or make changes to this bug.