Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356854 - subscription-manager status is not correct after register to rhsm
Summary: subscription-manager status is not correct after register to rhsm
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: ovirt-node
Classification: oVirt
Component: General
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ---
: ---
Assignee: Fabian Deutsch
QA Contact: Huijuan Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-15 07:18 UTC by Huijuan Zhao
Modified: 2016-07-18 16:41 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-18 16:41:01 UTC
oVirt Team: Node
rule-engine: planning_ack?
rule-engine: devel_ack?
cshao: testing_ack+


Attachments (Terms of Use)
screenshot of Cockpit Subscriptions page (deleted)
2016-07-15 07:18 UTC, Huijuan Zhao
no flags Details
All logs (deleted)
2016-07-15 07:20 UTC, Huijuan Zhao
no flags Details

Description Huijuan Zhao 2016-07-15 07:18:50 UTC
Created attachment 1180055 [details]
screenshot of Cockpit Subscriptions page

Description of problem:
After RHVH register to rhsm, subscription-manager status shows incorrect in cockpit and shell.


Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.0-20160714.3
imgbased-0.7.2-0.1.el7ev.noarch
cockpit-0.108-1.el7.x86_64
redhat-release-virtualization-host-4.0-0.20.el7.x86_64
kernel-3.10.0-327.22.2.el7.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Install RHVH redhat-virtualization-host-4.0-20160714.3
2. Reboot and login RHVH, register to rhsm:
   # subscription-manager register --username=** --password=** --serverurl=subscription.rhsm.stage.redhat.com 
   # subscription-manager subscribe --pool=8a99f98a55797b0b015582a1164e4d5b
     Successfully attached a subscription for: Red Hat Enterprise Virtualization (2-sockets), Premium
3. Check the subscription-manager status in shell and cockpit
   # subscription-manager status
  

Actual results:
After step3, subscription-manager status is not correct in shell and cockpit :
1. In shell:
# subscription-manager status
+-------------------------------------------+
   System Status Details
+-------------------------------------------+
Overall Status: Invalid

Red Hat Virtualization Host:
- Not supported by a valid subscription.
2. In cockpit Subscriptions page, the status shows as below(cockpit display, please refer to attachment):
   Not Subscribed (Not supported by a valid subscription.)

Expected results:
After step3, subscription-manager status in shell and cockpit should show correct(Subscribed).

Additional info:

Comment 1 Huijuan Zhao 2016-07-15 07:20:43 UTC
Created attachment 1180056 [details]
All logs

Comment 3 Huijuan Zhao 2016-07-18 03:40:58 UTC
Ryan, you are right, there is no such issue with your account registering, I will check and confirm QE account later

Comment 4 Fabian Deutsch 2016-07-18 16:41:01 UTC
Closing according to comment 3 - looks like an issue on the RHSM Server side.


Note You need to log in before you can comment on or make changes to this bug.