Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356758 - [RFE] add capacity information to the heketi-cli
Summary: [RFE] add capacity information to the heketi-cli
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: rhgs-3.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Michael Adam
QA Contact: Jonathan Holloway
URL:
Whiteboard:
: 1355697 (view as bug list)
Depends On:
Blocks: OCS-3.11.1-devel-triage-done
TreeView+ depends on / blocked
 
Reported: 2016-07-15 01:39 UTC by Paul Cuzner
Modified: 2019-01-23 19:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-23 19:11:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github heketi heketi issues 547 None None None 2016-10-17 20:38:46 UTC

Description Paul Cuzner 2016-07-15 01:39:06 UTC
Description of problem:
Managing one or multiple clusters with heketi would benefit from more information presented to the admin from the cli. Understanding the environment is a obviously a key deliverable of the solution, and providing a basic awareness of the capacity under the control of heketi would be a great start.

This RFE requests the following data is exposed

1. Each cluster should provide a roll-up summary consisting of the following fields;
- number of nodes in the cluster
- number of disks managed
- raw capacity managed
- raw capacity used
- raw %used
- number of volumes allocated


2. The topology view dumps all clusters, so a rollup of the cluster numbers would give a deployment wide view of the site
- total number of clusters managed
- total nodes
- total raw
- total raw used %
- total number of volumes allocated

By making this information available the admin will be able to
a) understand capacity utilisation
b) plan for more clusters or upgrades in timely manner (instead of encountering allocation failures and impacting the service offered to the business)

I would suggest that this information is added to the topology subcommand. From a usability perspective, I would also suggest that the topology info command is updated to include 
a) --cluster ... to limit topology and summary data to the specified cluster
b) --summary ... to limit the topology output to only the rollup data


Additional info:

Comment 2 Luis Pabón 2016-10-17 20:40:29 UTC
*** Bug 1355697 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.