Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356740 - cdn.redhat.com has the wrong repodata/productId version at server/7/7.2/ppc64 and server/7/7Server/ppc64
Summary: cdn.redhat.com has the wrong repodata/productId version at server/7/7.2/ppc64...
Keywords:
Status: CLOSED DUPLICATE of bug 1338857
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng
Version: 7.2
Hardware: ppc64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lubos Kocman
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-14 22:31 UTC by John Sefler
Modified: 2018-09-03 11:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-03 11:39:52 UTC


Attachments (Terms of Use)

Description John Sefler 2016-07-14 22:31:13 UTC
Description of problem:

AssertionError: Version of the productid on the CDN at 'https://cdn.redhat.com/content/dist/rhel/power/7/7.2/ppc64/os/repodata/productid' that will be installed by the yum product-id plugin after setting the subscription-manager release to '7.2'. expected:<7.2> but was:<7.1>

AssertionError: Version of the productid on the CDN at 'https://cdn.redhat.com/content/dist/rhel/power/7/7Server/ppc64/os/repodata/productid' that will be installed by the yum product-id plugin after setting the subscription-manager release to '7Server'. expected:<7.2> but was:<7.1>

Note: The expected productid version for '7Server' is the value of the current GA minor release of RHEL 7Server, which is currently '7.2'. 


Steps to Reproduce:
[root@ibm-p730-06-lp3 ~]# subscription-manager facts --list | grep distribution.name
distribution.name: Red Hat Enterprise Linux Server
[root@ibm-p730-06-lp3 ~]# subscription-manager facts --list | grep uname.machine
uname.machine: ppc64

[root@ibm-p730-06-lp3 ~]# subscription-manager register --serverurl=subscription.rhn.stage.redhat.com --baseurl=https://cdn.redhat.com --auto-attach --username=qa@redhat.com
Registering to: subscription.rhn.stage.redhat.com:443/subscription
Password: 
The system has been registered with ID: dbcb0cb4-3102-45df-9b6d-0c4fa5884882 

Installed Product Current Status:
Product Name: Red Hat Enterprise Linux for Power, big endian
Status:       Subscribed

[root@ibm-p730-06-lp3 ~]# subscription-manager repos --list-enabled
+----------------------------------------------------------+
    Available Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+
Repo ID:   rhel-7-for-power-rpms
Repo Name: Red Hat Enterprise Linux 7 for IBM Power (RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/power/7/$releasever/$basearch/os
Enabled:   1

[root@ibm-p730-06-lp3 ~]# ls /etc/pki/entitlement/
6517602492526942003-key.pem  6517602492526942003.pem

[root@ibm-p730-06-lp3 ~]# curl --stderr /dev/null --cert /etc/pki/entitlement/6517602492526942003.pem --key /etc/pki/entitlement/6517602492526942003-key.pem --cacert /etc/rhsm/ca/redhat-uep.pem https://cdn.redhat.com/content/dist/rhel/power/7/7.2/ppc64/os/repodata/productid > productid.pem && rct cat-cert productid.pem | grep -A8 "Product:"
Product:
	ID: 74
	Name: Red Hat Enterprise Linux for IBM POWER
	Version: 7.1    <========== BANG! Expected 7.2
	Arch: ppc64
	Tags: rhel-7,rhel-7-ibm-power
	Brand Type: 
	Brand Name: 

[root@ibm-p730-06-lp3 ~]# curl --stderr /dev/null --cert /etc/pki/entitlement/6517602492526942003.pem --key /etc/pki/entitlement/6517602492526942003-key.pem --cacert /etc/rhsm/ca/redhat-uep.pem https://cdn.redhat.com/content/dist/rhel/power/7/7Server/ppc64/os/repodata/productid > productid.pem && rct cat-cert productid.pem | grep -A8 "Product:"
Product:
	ID: 74
	Name: Red Hat Enterprise Linux for IBM POWER
	Version: 7.1   <========== BANG! Expected the current GA minor 7Server version which is 7.2
	Arch: ppc64
	Tags: rhel-7,rhel-7-ibm-power
	Brand Type: 
	Brand Name: 




Actual results:
  above

Expected results:
  Version: 7.2


Additional info:

Comment 3 Lubos Kocman 2017-01-04 16:33:22 UTC
Being solved as part of http://pub.devel.redhat.com/pub/push/105533/

Comment 7 Lubos Kocman 2018-09-03 11:39:52 UTC

*** This bug has been marked as a duplicate of bug 1338857 ***


Note You need to log in before you can comment on or make changes to this bug.