Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356731 - [Intel Haswell] graphics corruption in more complex OpenGL applications
Summary: [Intel Haswell] graphics corruption in more complex OpenGL applications
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 23
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Igor Gnatenko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-14 21:26 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2016-07-18 13:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-18 13:32:40 UTC


Attachments (Terms of Use)
A screenshot from wxmacmolplt showing the graphics corruption. (deleted)
2016-07-14 21:27 UTC, Dominik 'Rathann' Mierzejewski
no flags Details

Description Dominik 'Rathann' Mierzejewski 2016-07-14 21:26:59 UTC
Description of problem:
Since about a month, I'm experiencing graphics corruption in various OpenGL-using applications, for example Firefox or wxmacmolplt, but not in simpler ones like glxgears or glglobe.

Version-Release number of selected component (if applicable):
mesa: 11.1.0-4.20151218.fc23
mesa-libGLU-9.0.0-9.fc23
xorg-x11-drv-intel-2.99.917-19.20151206.fc23
kernel-4.5.7-202.fc23

How reproducible:
Always.

Steps to Reproduce:
1. Start wxmacmolplt
2. Click to add an atom

Actual results:
The red ball representing an atom is corrupted.

Expected results:
There should be a nice 3D-like sphere displayed.

Additional info:
This happens reproducibly on two Haswell-based laptops with just Intel GPUs that I have access to, but not on Radeon or nVidia. I tried downgrading the kernel, mesa and the intel X11 driver to no effect. I also tried disabling DRI3, the composite extension, and switching from SNA to EXA acceleration to no effect, either. Any assistance in identifying the culprit is welcome.

Comment 1 Dominik 'Rathann' Mierzejewski 2016-07-14 21:27:50 UTC
Created attachment 1179965 [details]
A screenshot from wxmacmolplt showing the graphics corruption.

Comment 2 Dominik 'Rathann' Mierzejewski 2016-07-14 21:35:54 UTC
Another application showing the issue is CriticalMass.

Comment 3 Igor Gnatenko 2016-07-14 21:36:22 UTC
Could you try on Fedora 24? mesa in F23 is a bit outdated, so it might be fixed already in F24.

Don't have Haswell in my hands, but on Ivy Bridge atom looks correct here.

Comment 4 Dominik 'Rathann' Mierzejewski 2016-07-18 13:28:26 UTC
I booted up Fedora 24 Live MATE desktop, installed wxmacmolplt and indeed, I cannot reproduce it there, so it seems to be F23-only.

Comment 5 Igor Gnatenko 2016-07-18 13:32:40 UTC
(In reply to Dominik 'Rathann' Mierzejewski from comment #4)
> I booted up Fedora 24 Live MATE desktop, installed wxmacmolplt and indeed, I
> cannot reproduce it there, so it seems to be F23-only.

Thanks a lot for testing. Unfortunately, make update for mesa in F23 is hard and I don't have time for this, so closing.


Note You need to log in before you can comment on or make changes to this bug.