Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356722 - computenode 7.2 has incorrect productid in repodata
Summary: computenode 7.2 has incorrect productid in repodata
Keywords:
Status: CLOSED DUPLICATE of bug 1338857
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lubos Kocman
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-14 20:54 UTC by John Sefler
Modified: 2018-09-03 11:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-03 11:39:37 UTC


Attachments (Terms of Use)

Description John Sefler 2016-07-14 20:54:05 UTC
Description of problem:

AssertionError: Version of the productid on the CDN at 'https://cdn.redhat.com/content/dist/rhel/computenode/7/7.2/x86_64/os/repodata/productid' that will be installed by the yum product-id plugin after setting the subscription-manager release to '7.2'. expected:<7.2> but was:<7.1>

Version of the productid on the CDN at 'https://cdn.redhat.com/content/dist/rhel/computenode/7/7ComputeNode/x86_64/os/repodata/productid' that will be installed by the yum product-id plugin after setting the subscription-manager release to '7ComputeNode'. expected:<7.2> but was:<7.1>


Steps to Reproduce:
[root@hp-dl380pgen8-02-vm-16 ~]# subscription-manager facts --list | grep distribution.name
distribution.name: Red Hat Enterprise Linux ComputeNode

[root@hp-dl380pgen8-02-vm-16 ~]# subscription-manager register --serverurl=subscription.rhn.stage.redhat.com --baseurl=https://cdn.redhat.com --auto-attach --username=qa@redhat.com
Registering to: subscription.rhn.stage.redhat.com:443/subscription
Password: 
The system has been registered with ID: 666c2885-c932-4dcd-9a54-dc937fa3ad1b 

Installed Product Current Status:
Product Name: Red Hat Enterprise Linux for Scientific Computing
Status:       Subscribed

[root@hp-dl380pgen8-02-vm-16 ~]# subscription-manager repos --list-enabled
+----------------------------------------------------------+
    Available Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+
Repo ID:   rhel-7-hpc-node-rpms
Repo Name: Red Hat Enterprise Linux 7 for Scientific Computing (RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/computenode/7/$releasever/$basearch/os
Enabled:   1

[root@hp-dl380pgen8-02-vm-16 ~]# uname -i
x86_64

[root@hp-dl380pgen8-02-vm-16 ~]# ls /etc/pki/entitlement/
998409028260483591-key.pem  998409028260483591.pem

[root@hp-dl380pgen8-02-vm-16 ~]# curl --stderr /dev/null --cert /etc/pki/entitlement/998409028260483591.pem --key /etc/pki/entitlement/998409028260483591-key.pem --cacert /etc/rhsm/ca/redhat-uep.pem https://cdn.redhat.com/content/dist/rhel/computenode/7/7.2/x86_64/os/repodata/productid > productid.pem && rct cat-cert productid.pem | grep -A8 "Product:"
Product:
	ID: 76
	Name: Red Hat Enterprise Linux for Scientific Computing
	Version: 7.1    <========== BANG! Expected 7.2
	Arch: x86_64
	Tags: rhel-7,rhel-7-computenode
	Brand Type: 
	Brand Name: 

[root@hp-dl380pgen8-02-vm-16 ~]# curl --stderr /dev/null --cert /etc/pki/entitlement/998409028260483591.pem --key /etc/pki/entitlement/998409028260483591-key.pem --cacert /etc/rhsm/ca/redhat-uep.pem https://cdn.redhat.com/content/dist/rhel/computenode/7/7ComputeNode/x86_64/os/repodata/productid > productid.pem && rct cat-cert productid.pem | grep -A8 "Product:"
Product:
	ID: 76
	Name: Red Hat Enterprise Linux for Scientific Computing
	Version: 7.1   <========== BANG! Expected the current GA minor 7ComputeNode version which is 7.2
	Arch: x86_64
	Tags: rhel-7,rhel-7-computenode
	Brand Type: 
	Brand Name: 





Actual results:
  above

Expected results:
  Version: 7.2

Additional info:

Comment 2 Lubos Kocman 2017-02-02 09:26:30 UTC
Adding dev_ack+ I plan to repush all eus productids, since we do have 3+ bugs for it
7ComputeNode should be already fixed

Lubos

Comment 3 Lubos Kocman 2017-02-03 11:34:47 UTC
Fixed by http://pub.devel.redhat.com/pub/push/108570/
Please re-open this issue if it's still a problem.

Lubos

Comment 5 Lubos Kocman 2018-09-03 11:39:37 UTC

*** This bug has been marked as a duplicate of bug 1338857 ***


Note You need to log in before you can comment on or make changes to this bug.