Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356721 - Able to select stale provisioned hosts as discovered hosts
Summary: Able to select stale provisioned hosts as discovered hosts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.0
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ga
: 1.0
Assignee: cchase
QA Contact: Tasos Papaioannou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-14 20:51 UTC by Dylan Murray
Modified: 2016-09-13 16:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:31:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description Dylan Murray 2016-07-14 20:51:26 UTC
Description of problem:
On 2(B,C), I am able to select previously used hosts as my engine and hypervisor if a previous deployment hasn't finished converting hosts to managed hosts. This will cause unforeseen wizard errors like for example during an OSE deployment the transition to 3(A) fails and no error is printed. We should not be able to select hosts allocated by other deployments.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Launch a deployment using two discovered hosts
2. During provisioning, start a new deployment using the same two hosts selected previously
3. If using OSE, try to go to 3(A)

Actual results:

Transition fails and no error is output

Expected results:

Either unable to select these hosts or an error is displayed explaining the discovered hosts are invalid.

Additional info:

Comment 8 cchase 2016-07-22 17:37:57 UTC
https://github.com/fusor/fusor/pull/1083

- Added review validation that no other fusor deployment is running.
- Added review validation that deployment's hosts are not already managed.
- Added filter for engine/hypervisor discovered hosts pages to omit hosts associated with a currently running deployment.

Comment 9 John Matthews 2016-07-25 12:41:56 UTC
QCI-1.0-RHEL-7-20160723.t.0-QCI-x86_64-dvd1.iso

Note, the validation for deployment host not being managed was removed.

Comment 10 Tasos Papaioannou 2016-08-19 14:48:01 UTC
Verified on QCI-1.0-RHEL-7-20160818.t.2:

- While a deployment is underway, a new deployment cannot see/select those discovered hosts.
- Installation Review tab of new deployment shows "Fusor::Deployment|Satellite task uuid Deployment 1: tpapaioa-1 is already running" warning, and Next button is disabled.

Comment 12 errata-xmlrpc 2016-09-13 16:31:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.