Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356673 - rubygem-rest-client: 2.0.0 is available
Summary: rubygem-rest-client: 2.0.0 is available
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rubygem-rest-client
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vít Ondruch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1356650
Blocks: 907393
TreeView+ depends on / blocked
 
Reported: 2016-07-14 16:23 UTC by Jun Aruga
Modified: 2016-07-25 15:30 UTC (History)
2 users (show)

Fixed In Version: rubygem-rest-client-2.0.0-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-25 15:30:23 UTC


Attachments (Terms of Use)
Update to 2.0.0 (deleted)
2016-07-14 16:30 UTC, Jun Aruga
no flags Details | Diff

Description Jun Aruga 2016-07-14 16:23:20 UTC
Description of problem:

I want to update rubygem-rest-client from 1.8.0 to 2.0.0.
Because the 2.0.0 supports mime-types latest version 3.1, that is likely to be needed by Rails 5.0.0.
I prepared the patch to update to 2.0.0. I am going to upload it here soon.

I also like you guys to update "Monitoring on", monitor the upstream version up.
https://admin.fedoraproject.org/pkgdb/package/rpms/rubygem-rest-client/

Comment 1 Jun Aruga 2016-07-14 16:30:19 UTC
Created attachment 1179912 [details]
Update to 2.0.0

Could you check my patch?

# Dependency for rawhide.

$ dnf repoquery --disablerepo=* --enablerepo=rawhide --whatrequires 'rubygem(rest-client)'
rubygem-apipie-bindings-0:0.0.15-2.fc24.noarch
  rpm spec: ok
  gem spec: ok
    https://rubygems.org/gems/apipie-bindings/versions/0.0.15
rubygem-deltacloud-client-0:1.1.2-7.fc24.noarch
  rpm spec: ok
  gem spec: ok
    https://rubygems.org/gems/deltacloud-client/versions/1.1.2

rubygem-dynect_rest-0:0.4.3-6.fc20.noarch
  rpm spec: ok
  gem spec: ok
    https://rubygems.org/gems/dynect_rest/versions/0.4.3

rubygem-foreman_api-0:0.1.11-4.fc24.noarch
  rpm spec: ok
  gem spec: ok
    https://rubygems.org/gems/foreman_api/versions/0.1.11

rubygem-heroku-0:3.41.3-2.fc24.noarch
  rpm spec: ok
  gem spec: ok
    https://rubygems.org/gems/heroku/versions/3.41.3

rubygem-morph-cli-0:0.2.2-4.fc24.noarch
  rpm spec: ok
  gem spec: ok
    https://rubygems.org/gems/morph-cli/versions/0.2.2

rubygem-rbovirt-0:0.0.35-3.fc24.noarch
  rpm spec: ok
  gem spec: ok
    https://rubygems.org/gems/rbovirt/versions/0.0.35

vagrant-0:1.8.1-2.fc25.noarch
  rpm spec: ng
    asking.
    https://bugzilla.redhat.com/show_bug.cgi?id=1356650


$ dnf repoquery --disablerepo=* --enablerepo=rawhide --whatrequires 'rubygem-rest-client'
rubygem-rest-client-doc-0:1.8.0-2.fc24.noarch
  ok

$ dnf repoquery --disablerepo=* --enablerepo=rawhide --arch src --whatrequires 'rubygem(rest-client)'
  no target

$ dnf repoquery --disablerepo=* --enablerepo=rawhide --arch src --whatrequires 'rubygem-rest-client'
  no target

Comment 2 Vít Ondruch 2016-07-15 07:41:21 UTC
(In reply to Jun Aruga from comment #0)
> I also like you guys to update "Monitoring on", monitor the upstream version
> up.
> https://admin.fedoraproject.org/pkgdb/package/rpms/rubygem-rest-client/

The monitoring is enabled ... not sure why Anitya did not reported the updated version into BZ ...

Comment 3 Jun Aruga 2016-07-15 08:31:32 UTC
(In reply to Vít Ondruch from comment #2)
> (In reply to Jun Aruga from comment #0)
> > I also like you guys to update "Monitoring on", monitor the upstream version
> > up.
> > https://admin.fedoraproject.org/pkgdb/package/rpms/rubygem-rest-client/
> 
> The monitoring is enabled ... not sure why Anitya did not reported the
> updated version into BZ ...

Okay, I got it. Humm.

Comment 4 Jun Aruga 2016-07-15 08:41:51 UTC
(In reply to Vít Ondruch from comment #2)
> (In reply to Jun Aruga from comment #0)
> > I also like you guys to update "Monitoring on", monitor the upstream version
> > up.
> > https://admin.fedoraproject.org/pkgdb/package/rpms/rubygem-rest-client/
> 
> The monitoring is enabled ... not sure why Anitya did not reported the
> updated version into BZ ...

Vit I could see "Monitoring: No monitoring" from the URL.
Is this the reason, isn't it?
https://admin.fedoraproject.org/pkgdb/package/rpms/rubygem-rest-client/

Comment 5 Vít Ondruch 2016-07-15 10:40:24 UTC
(In reply to Jun Aruga from comment #4)
That is actually combo of 3 options:

1. No monitoring
2. Bugs & builds
3. Bugs only

where the middle is marked by arrow, i.e. it is active.

Comment 6 Vít Ondruch 2016-07-15 10:40:59 UTC
(In reply to Vít Ondruch from comment #5)
> That is actually combo of 3 options:

s/combo/radio button/

Comment 7 Jun Aruga 2016-07-15 11:21:42 UTC
(In reply to Vít Ondruch from comment #5)
> (In reply to Jun Aruga from comment #4)
> That is actually combo of 3 options:
> 
> 1. No monitoring
> 2. Bugs & builds
> 3. Bugs only
> 
> where the middle is marked by arrow, i.e. it is active.

Ah I got it.

Comment 8 Jun Aruga 2016-07-18 11:33:38 UTC
Hi, could you check my patch?

(In reply to Jun Aruga from comment #1)
> Created attachment 1179912 [details]
> Update to 2.0.0

Comment 9 Vít Ondruch 2016-07-25 15:30:23 UTC
Thank you. I applied the patch in Rawhide.


Note You need to log in before you can comment on or make changes to this bug.