Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356650 - vagrant: Want to use rest-client 2.0
Summary: vagrant: Want to use rest-client 2.0
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vagrant
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vít Ondruch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1356673
TreeView+ depends on / blocked
 
Reported: 2016-07-14 15:04 UTC by Jun Aruga
Modified: 2016-07-25 14:45 UTC (History)
5 users (show)

Fixed In Version: vagrant-1.8.1-3.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-25 14:45:58 UTC


Attachments (Terms of Use)
Support rest-client 2.x (deleted)
2016-07-18 11:31 UTC, Jun Aruga
no flags Details | Diff

Description Jun Aruga 2016-07-14 15:04:26 UTC
Description of problem:

I want to update rubygem-rest-client from 1.8 to 2.0.
However vagrant RPM spec file depends on rubygem(rest-client) < 2.0 .

Could you change from "rubygem(rest-client) < 2.0" to "rubygem(rest-client)" in the spec file?

Thanks.


Additional info:
The reason why I want to update rubygem-rest-client to 2.0 is

rest-client-1.8 depends on mime-types < 3.
rest-client-2.0 supports latest version: mime-types 3.1.
Finally I want to use mime-types 3.1.

Comment 1 Vít Ondruch 2016-07-15 07:35:43 UTC
(In reply to Jun Aruga from comment #0)
> Could you change from "rubygem(rest-client) < 2.0" to "rubygem(rest-client)"
> in the spec file?

This dependency is autogenerated and comes from upstream:

https://github.com/mitchellh/vagrant/blob/master/vagrant.gemspec#L34

You probably want to investigate why the dependency is restricted to "< 2.0" and discuss with upstream first.

Comment 2 Jun Aruga 2016-07-15 08:29:36 UTC
(In reply to Vít Ondruch from comment #1)
> (In reply to Jun Aruga from comment #0)
> > Could you change from "rubygem(rest-client) < 2.0" to "rubygem(rest-client)"
> > in the spec file?
> 
> This dependency is autogenerated and comes from upstream:
> 
> https://github.com/mitchellh/vagrant/blob/master/vagrant.gemspec#L34
> 
> You probably want to investigate why the dependency is restricted to "< 2.0"
> and discuss with upstream first.

okay, thanks for your information!

Comment 3 Jun Aruga 2016-07-15 11:19:20 UTC
(In reply to Jun Aruga from comment #2)
> (In reply to Vít Ondruch from comment #1)
> > (In reply to Jun Aruga from comment #0)
> > > Could you change from "rubygem(rest-client) < 2.0" to "rubygem(rest-client)"
> > > in the spec file?
> > 
> > This dependency is autogenerated and comes from upstream:
> > 
> > https://github.com/mitchellh/vagrant/blob/master/vagrant.gemspec#L34
> > 
> > You probably want to investigate why the dependency is restricted to "< 2.0"
> > and discuss with upstream first.
> 
> okay, thanks for your information!

Asking here, I could passed upstream's unit test with Ruby 2.2.5 and 2.2.3 after I updated the dependency.
https://github.com/mitchellh/vagrant/pull/7589

Comment 4 Jun Aruga 2016-07-18 09:51:56 UTC
(In reply to Jun Aruga from comment #3)
> Asking here, I could passed upstream's unit test with Ruby 2.2.5 and 2.2.3
> after I updated the dependency.
> https://github.com/mitchellh/vagrant/pull/7589

Vit,
My patch to use rest-client 2.0 was accepted to the upstream.
I am going to prepare the patch to use rest-client 2.0 for this vagrant package, and upload it here.

Comment 5 Jun Aruga 2016-07-18 11:31:27 UTC
Created attachment 1181023 [details]
Support rest-client 2.x

Hi,
I created the patch to support rest-client 2.x.
Could you check my patch?
Thanks.

Comment 6 Vít Ondruch 2016-07-25 14:45:58 UTC
Thx for the patch. I applied it in Rawhide.


Note You need to log in before you can comment on or make changes to this bug.