Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356644 - "Ports for Satellite to Capsule Communication" need to include port 443
Summary: "Ports for Satellite to Capsule Communication" need to include port 443
Keywords:
Status: CLOSED DUPLICATE of bug 1353350
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide
Version: 6.1.9
Hardware: Unspecified
OS: Unspecified
low
medium vote
Target Milestone: Unspecified
Assignee: satellite-doc-list
QA Contact: satellite-doc-list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-14 14:51 UTC by Pavel Moravec
Modified: 2016-07-14 15:06 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-14 15:06:44 UTC


Attachments (Terms of Use)

Description Pavel Moravec 2016-07-14 14:51:02 UTC
Document URL: 

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html-single/Installation_Guide/index.html#sect-Red_Hat_Satellite-Installation_Guide-Red_Hat_Satellite_Capsule_Server_Prerequisites-Network_Ports_Required_for_Capsule_Communications


Section Number and Name: 

7.2.3. Network Ports Required for Capsule Communications


Describe the issue: 

"Table 7.1. Ports for Satellite to Capsule Communication" needs to contain also port 443. Since during synchronizing content from Satellite to Capsule (after publishing a Content View, within Actions::Katello::ContentView::CapsuleGenerateAndSync foreman task and in  Actions::Pulp::Repository::DistributorPublishChanges step in particular), Satellite sends a request to Capsule's https directly, expecting Satellite->Capsule:443 connection can be established.


Suggestions for improvement: 

See above.


Additional information: 

No need of updating firewall settings (that is covered by client->capsule:443). Just mention the port 443 in table 7.1. Since there can be (and already is) a customer who blocks everything except specifically listed ports along the path as well, such that opening the port on Capsule's firewall is not sufficient.

Comment 1 Pavel Moravec 2016-07-14 15:06:44 UTC

*** This bug has been marked as a duplicate of bug 1353350 ***


Note You need to log in before you can comment on or make changes to this bug.