Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356636 - QCI 1.2: when "Do not configure network" is selected, network should not be restarted.
Summary: QCI 1.2: when "Do not configure network" is selected, network should not be ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: fusor-installer
Version: 1.0
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ga
: 1.0
Assignee: Jason Montleon
QA Contact: James Olin Oden
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-14 14:12 UTC by James Olin Oden
Modified: 2016-09-13 16:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:31:45 UTC


Attachments (Terms of Use)
/var/log/messages during the time of running fusor-installer. (deleted)
2016-07-19 19:08 UTC, James Olin Oden
no flags Details
Answers file (deleted)
2016-07-19 19:10 UTC, James Olin Oden
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description James Olin Oden 2016-07-14 14:12:30 UTC
Description of problem:
Presently if you select "Do ont configure network" in fusor installer, and then 
select "Proceed with values shown" it will not configure the network, but it 
will restart the network, named, and dhcpd.   It really should not restart any of these services if the network was not configured by fusor-installer.

Version-Release number of selected component (if applicable):
QCI-1.2-RHEL-7-20160713.t.1

How reproducible:
Every time.

Steps to Reproduce:
1. Select "Do not configure networking" in fusor installer  
2. Select "Proceed with values show"


Actual results:
It will eventually restart the network, named and dhcpd.

Expected results:
It should not restart these services.

Comment 2 Jason Montleon 2016-07-19 18:30:43 UTC
Can you add /var/log/messages and /etc/fusor-installer/fusor-installer.answers.yaml from an affected host, please? 

This is possibly being done by a 'notify => Service['network']' line somewhere in the network puppet module though I'd be interested to know how we're getting there if configure_networking is false.

modules/fusor_network/manifests/init.pp:
"  if ($configure_networking) {
    class { 'network::global':
      gateway => $gateway,
    }
"

Just running the installer I did not see that the network service was restarted and I'm not seeing where dhcpd or named would be restarted from aside from foreman-installer, which is configuring both, so I'd fully expect both to get restarted.

Comment 4 James Olin Oden 2016-07-19 19:08:31 UTC
Created attachment 1181790 [details]
/var/log/messages during the time of running fusor-installer.

Comment 5 James Olin Oden 2016-07-19 19:10:43 UTC
Created attachment 1181791 [details]
Answers file

Comment 8 John Matthews 2016-07-20 23:47:55 UTC
Rebuilt fusor-initial-setup in brew, but did not pick this up for the 7/20.0 compose.

Next compose will have this fix.

Comment 12 John Matthews 2016-07-25 12:43:43 UTC
QCI-1.0-RHEL-7-20160723.t.0-QCI-x86_64-dvd1.iso

Comment 14 errata-xmlrpc 2016-09-13 16:31:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.