Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356623 - [RFE] CM provider should enable OpenShift cluster deployment, using the Automation Engine combined with the openshift-ansible installer
Summary: [RFE] CM provider should enable OpenShift cluster deployment, using the Autom...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: Beta 1
: cfme-future
Assignee: Loic Avenel
QA Contact: Dafna Ron
URL:
Whiteboard: container
Depends On:
Blocks: 1356999 1359152 1361169
TreeView+ depends on / blocked
 
Reported: 2016-07-14 13:50 UTC by Daniel Korn
Modified: 2017-08-28 15:00 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1356999 1359152 1361169 (view as bug list)
Environment:
Last Closed: 2017-08-28 15:00:43 UTC
Category: Feature
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Korn 2016-07-14 13:50:37 UTC
Description of problem:
This feature will enable OpenShift cluster deployment.
There will be 3 types of deployment:
1. use existing VMs from an existing managed provider
2. create new VMs on a managed provider for AWS and RHEV
3. use unmanaged hosts

This feature should expose an Angular based Wizard UI, to walk the user through the various configurations options (topology, authentication, storage settings and more).
The deployment itself is performed by the openshift-ansible installer, triggered by a state-machine in the Automation Engine.

Comment 6 Chris Pelland 2017-08-28 15:00:43 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.