Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356577 - sssctl: Time stamps without time zone information
Summary: sssctl: Time stamps without time zone information
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Fabiano Fidêncio
QA Contact: Steeve Goveas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-14 12:15 UTC by Marc Muehlfeld
Modified: 2017-10-26 09:09 UTC (History)
8 users (show)

Fixed In Version: sssd-1.14.0-10.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 07:19:46 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2476 normal SHIPPED_LIVE sssd bug fix and enhancement update 2016-11-03 14:08:11 UTC

Description Marc Muehlfeld 2016-07-14 12:15:44 UTC
Description of problem:
sssctl shows time stamps in UTC. Either "UTC" should be added to the time stamps or the time should be converted to the local time zone.



Version-Release number of selected component (if applicable):
sssd-tools-1.14.0-3.fc25.x86_64



Steps to Reproduce:
1. Show the current time:
    # date
    Do 14. Jul 13:55:20 CEST 2016
2. Verify that a user is not in the cache
    # sssctl user admin
3. Get the user cached
    # getent passwd admin
    admin:*:373000000:373000000:Administrator:/home/admin:/bin/bash
4. Show the cache information:
    # sssctl user admin
    Name: admin
    Cache entry creation date: 07/14/16 11:55:17
    Cache entry last update time: 07/14/16 11:55:17
    Cache entry expiration time: 07/14/16 13:25:17
    Initgroups expiration time: Initgroups were not yet performed
    Cached in InfoPipe: No



Actual results:
Time stamps are shown in UTC without telling the user.



Expected results:
Time stamps should be either converted to the local time zone or "UTC" added.

Comment 2 Jakub Hrozek 2016-07-14 15:03:21 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/3096

Comment 3 Lukas Slebodnik 2016-07-18 14:40:36 UTC
master:
* f316e5446313bbf61c96b6763badc21604bff4a3

Comment 7 shridhar 2016-09-15 12:10:45 UTC
Verified with  
]# rpm -q sssd
sssd-1.14.0-38.el7.x86_64

[root@dell-pesc1425-02 ~]# date ; id testuser1012
Thu Sep 15 08:09:35 EDT 2016
uid=1012(testuser1012) gid=1012(testuser1012) groups=1012(testuser1012),444412(dbgroup)

[root@dell-pesc1425-02 ~]# sssctl user-show testuser1012
Name: testuser1012
Cache entry creation date: 09/15/16 08:09:35
Cache entry last update time: 09/15/16 08:09:35
Cache entry expiration time: 09/15/16 09:39:35
Initgroups expiration time: 09/15/16 09:39:35
Cached in InfoPipe: No
[root@dell-pesc1425-02 ~]# 



Timestamps are shown in local timezone.

Comment 9 errata-xmlrpc 2016-11-04 07:19:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2476.html


Note You need to log in before you can comment on or make changes to this bug.