Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356562 - [ALL_LANGS] Untranslated strings in Disks->Upload: Browse button and related messages
Summary: [ALL_LANGS] Untranslated strings in Disks->Upload: Browse button and related ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.1.0.3
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: ovirt-4.2.0
: 4.2.0
Assignee: Bhushan Barve
QA Contact: Bhushan Barve
URL:
Whiteboard:
Depends On: 1435402
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-14 11:40 UTC by Krishna Babu K
Modified: 2018-04-18 12:32 UTC (History)
10 users (show)

Fixed In Version: rhv-4.2.0-5
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-18 12:32:42 UTC
oVirt Team: i18n
rule-engine: ovirt-4.2+
rule-engine: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
Screen shot reference for the reported issue. (deleted)
2016-07-14 11:40 UTC, Krishna Babu K
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 72461 master MERGED webadmin: support translation on FileUpload 2017-02-22 19:53:19 UTC
oVirt gerrit 72946 ovirt-engine-4.1 MERGED webadmin: support translation on FileUpload 2017-02-23 12:59:57 UTC

Description Krishna Babu K 2016-07-14 11:40:44 UTC
Created attachment 1179769 [details]
Screen shot reference for the reported issue.

Description of problem:
  While uploading disks in RHEVM with non en_US locales, the 'Disks'->'Upload' window has untranslated entries "Browse..." and "No file selected"

Version-Release number of selected component (if applicable):
   RHEVM Version: 4.0.2-0.2.rc1.el7ev

How reproducible:
Always

Steps to Reproduce:
1. Log into RHEVM administration portal with non en_US locales.
2. Navigate to 'Disks'->'Upload'
3. One can observe untranslated 'Browser...' button as well 'No file selected' status.
4. Mouse hover over 'Browser...' button shows untranslated tool tip message 'No file selected'

Actual results:
  Translations are not available.

Expected results:
  Translations should available.

Additional info:
  Screen-shot attached as a reference.

Comment 1 Krishna Babu K 2016-08-05 09:47:35 UTC
Verified on RHEVM 4.0.2.4-0.1 , reported issue is still reproducible.

Comment 2 Daniel Erez 2017-02-16 17:18:49 UTC
Added translation support for FileUpload.
The new strings should be translated in Zanata.

Comment 3 Allon Mureinik 2017-03-19 15:28:17 UTC
This is already merge to ovirt-engine-4.1.
Shouldn't it be on MODIFIED?

Comment 4 Daniel Erez 2017-03-19 17:18:36 UTC
(In reply to Allon Mureinik from comment #3)
> This is already merge to ovirt-engine-4.1.
> Shouldn't it be on MODIFIED?

I'm still waiting for the translations to be merged...

Comment 5 Allon Mureinik 2017-03-20 15:50:23 UTC
Greg - how to we proceed with tracking this BZ? There's no point in leaving it on Daniel/Storage, as neither he, nor anyone else from the team can provide the translations.

Comment 6 Greg Sheremeta 2017-03-20 17:40:17 UTC
At this point, we move it to the i18n component and assign to Yuko.

The last upload Scott did to Zanata was 5-Jan-2017, but these new keys were merged after that. Unless this is an urgent translation need, I will push this to 4.2 translation cycle.

Comment 7 Scott Dickerson 2017-03-21 21:38:10 UTC
I can verify that translations for this change have not been made in 4.1 and are not currently available on the ovirt-4.1 version of the zanata project [1].  The strings will be available for translation, and will be translated, in the 4.2 translation cycle.  This hasn't been scheduled yet.

Unless there is a critical need to verify that translations are available and have been made for this bug, it can be closed normally.  Translations will be performed and verified in the 4.2 translation cycle.


[1] - https://translate.zanata.org/iteration/view/ovirt/ovirt-4.1

Comment 8 Scott Dickerson 2017-03-23 17:55:16 UTC
This bug has been made dependent on the first translation cycle of oVrit 4.2 (1435402).  Once that translation cycle is complete, and the translations have been merged to gerrit, this bug can be tested appropriately.

Comment 9 Yaniv Kaul 2017-12-06 15:34:07 UTC
Any idea why it isn't in MODIFIED state?

Comment 10 Bhushan Barve 2017-12-07 11:57:51 UTC
(In reply to Yaniv Kaul from comment #9)
> Any idea why it isn't in MODIFIED state?

Not sure why I'm the Assignee here. QA contact is fine, being from QE team (i18n-qe)

Comment 11 Yaniv Kaul 2017-12-07 12:01:16 UTC
(In reply to Bhushan Barve from comment #10)
> (In reply to Yaniv Kaul from comment #9)
> > Any idea why it isn't in MODIFIED state?
> 
> Not sure why I'm the Assignee here. QA contact is fine, being from QE team
> (i18n-qe)

Scott?

Comment 12 Allon Mureinik 2017-12-07 13:11:55 UTC
Commit e9bf24a87c102efba09bdececff0a8ac59678e88 includes the latest translation cycle from Zanata which should include the iamgeio strings that the engine patch was missing, at least for some languages.

E.g., the key "uploadImageChooseFile=Choose File" has a Japanese override, but doesn't have a German or French override.
I'm not sure if this is intentional (since this string doesn't need translation) or a bug. Regardless, moving to ON_QA so that the I18N stakeholders can either verify or fail this BZ.

Comment 13 Scott Dickerson 2017-12-07 20:03:07 UTC
Bhushan was set as assignee back in March when a few of us were discussing how to handle i18n bugs from 4.1 that wouldn't see translations until 4.2.  This BZ, like others, were set to be blocked by 1435402.  Once the blocker was completed, they should all transition to MODIFIED.

I reassigned the bug to Bhushan in an attempt to make it easier to find/remember the test this BZ again late in the release cycle.  Going forward we can do things differently to cause less confusion.

Comment 14 Bhushan Barve 2018-04-09 13:46:50 UTC
Checked with 4.2.2.4-0.1.el7

The browse button and the status message is translated now for all the locales. There is no tool-tip now for the same in 4.2. 

Marking it as verified. Please re-open in case of any issues.

Comment 15 Sandro Bonazzola 2018-04-18 12:32:42 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.