Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356537 - Ballooning will not work when IO QoS is not defined
Summary: Ballooning will not work when IO QoS is not defined
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mom
Version: 3.6.8
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ovirt-3.6.9
: 3.6.9
Assignee: Martin Sivák
QA Contact: meital avital
URL:
Whiteboard:
Depends On: 1346252 1361554
Blocks: 1348263
TreeView+ depends on / blocked
 
Reported: 2016-07-14 10:38 UTC by Martin Sivák
Modified: 2016-07-29 12:09 UTC (History)
16 users (show)

Fixed In Version: mom-0.5.5-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1346252
Environment:
Last Closed: 2016-07-27 14:20:11 UTC
oVirt Team: SLA


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1508 normal SHIPPED_LIVE MOM bug fix update 2016-07-27 18:18:23 UTC
oVirt gerrit 59460 None None None 2016-07-14 10:38:04 UTC

Description Martin Sivák 2016-07-14 10:38:04 UTC
This bug is needed for the errata process.

+++ This bug was initially created as a clone of Bug #1346252 +++

Description of problem:
Mom will be doing nothing for VMs that have no IO QoS defined
Mom logs, reports missing fields for the vm:
Incomplete data: missing set(['io_tune_current', 'io_tune'])

Version-Release number of selected component (if applicable):
mom-0.5.4-1.el7ev.noarch


How reproducible:
100%

Steps to Reproduce:
1. Run VM with guest agent 
2. check mom logs, if you get: getVmBalloonInfo() is not ready ->> then the VM is not ready and no policy will be evaluated on it

3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Martin Sivák on 2016-06-14 13:48:14 CEST ---

We need to create GuestIoTuneOptional collector in MOM and then use it in VDSM's configuration file for MOM.

--- Additional comment from Roy Golan on 2016-06-15 08:00:27 CEST ---

Is the evaluation of policy is such inclusive? isn't it triggered with minimum requirements? If not it should be

--- Additional comment from Martin Sivák on 2016-06-15 10:21:28 CEST ---

(In reply to Roy Golan from comment #2)
> Is the evaluation of policy is such inclusive? isn't it triggered with
> minimum requirements? If not it should be

Uh? That is the whole point of this bug. The currently used GuestIoTune adds the io_tune variables to the list of required values.

--- Additional comment from Doron Fediuck on 2016-06-20 10:26:01 CEST ---



--- Additional comment from Red Hat Bugzilla Rules Engine on 2016-06-20 10:59:19 CEST ---

This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 1 Yaniv Lavi 2016-07-14 12:28:24 UTC
Is this really MODIFIED? Where the the backports?

Comment 2 Martin Sivák 2016-07-14 12:31:54 UTC
Yes this is modified, mom-0.5.5 has been in brew for weeks and we tagged it for 3.6 this week.

Comment 9 errata-xmlrpc 2016-07-27 14:20:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1508.html


Note You need to log in before you can comment on or make changes to this bug.