Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356508 - [RFE] Handle errors during SSH key generation(gsec_create)
Summary: [RFE] Handle errors during SSH key generation(gsec_create)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-14 09:50 UTC by Aravinda VK
Modified: 2017-03-27 18:20 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-27 18:20:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2016-07-14 09:50:35 UTC
Description of problem:
Existing command will not how SSH keygen error messages when a peer node is down. gsec_create should show the summary of keygen status.

Comment 1 Vijay Bellur 2016-07-14 09:52:51 UTC
REVIEW: http://review.gluster.org/14732 (geo-rep: Alternate command to generate SSH Keys) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Aravinda VK 2016-07-14 10:02:12 UTC
Introduced new alternate command instead of changing already existing command.

Usage: 

    gluster-georep-sshkey generate
    or
    gluster-georep-sshkey generate --no-prefix

Above commands are equivalents of `gluster system:: execute gsec_create` and `gluster system:: execute gsec_create container` respectively.

After one release we can deprecate and remove the old command.

Comment 3 Vijay Bellur 2016-08-04 09:24:21 UTC
REVIEW: http://review.gluster.org/14732 (geo-rep: Alternate command to generate SSH Keys) posted (#3) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 4 Vijay Bellur 2016-08-09 07:34:16 UTC
REVIEW: http://review.gluster.org/14732 (geo-rep: Alternate command to generate SSH Keys) posted (#4) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 5 Worker Ant 2016-08-25 08:16:38 UTC
REVIEW: http://review.gluster.org/14732 (geo-rep: Alternate command to generate SSH Keys) posted (#5) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 6 Worker Ant 2016-08-30 14:07:19 UTC
REVIEW: http://review.gluster.org/14732 (geo-rep: Alternate command to generate SSH Keys) posted (#6) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 7 Worker Ant 2016-08-31 05:36:28 UTC
REVIEW: http://review.gluster.org/14732 (geo-rep: Alternate command to generate SSH Keys) posted (#7) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 8 Worker Ant 2016-08-31 10:09:16 UTC
COMMIT: http://review.gluster.org/14732 committed in master by Aravinda VK (avishwan@redhat.com) 
------
commit 29a57765d524af8ec0e5bab17e5ff7f47b968342
Author: Aravinda VK <avishwan@redhat.com>
Date:   Wed Jun 15 13:54:37 2016 +0530

    geo-rep: Alternate command to generate SSH Keys
    
    `gluster system:: execute gsec_create` is used to generate SSH
    Keys in all Master nodes and collect public keys in command initiated
    node. But this tool will not provide details if a peer node is down and
    unable to generate keys.
    
    New command will be introduced to create SSH Keys in all peer nodes.
    
    Usage:
    
        gluster-georep-sshkey generate
        or
        gluster-georep-sshkey generate --no-prefix
    
    Generates two SSH keys(one for gsyncd access and other for tar) in all
    peer nodes and collects the public keys to the local node where it is
    initiated. Adds `command=` prefix to common_secret.pem.pub if `--no-prefix`
    argument is not set.
    
    Shows status as below,
    
    +-----------+-------------+---------------+
    |    NODE   | NODE STATUS | KEYGEN STATUS |
    +-----------+-------------+---------------+
    |    fvm2   |          UP |            OK |
    | localhost |          UP |            OK |
    +-----------+-------------+---------------+
    
    BUG: 1356508
    Change-Id: Ib202811f41f9986694f07d9eedba31db6ed4d18f
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/14732
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>

Comment 9 Shyamsundar 2017-03-27 18:20:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.