Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356480 - [virtio-win][vioser+viorng][whql] Win10&2016 guest BSOD when run job "DF - HyperVisor Code Integrity Readiness Test"
Summary: [virtio-win][vioser+viorng][whql] Win10&2016 guest BSOD when run job "DF - Hy...
Keywords:
Status: CLOSED DUPLICATE of bug 1356422
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Gal Hammer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-14 08:42 UTC by Peixiu Hou
Modified: 2016-07-18 13:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-18 13:25:56 UTC


Attachments (Terms of Use)
122SRLWIN2016 hlk package (deleted)
2016-07-14 08:42 UTC, Peixiu Hou
no flags Details
BSOD on win2016 (deleted)
2016-07-14 08:44 UTC, Peixiu Hou
no flags Details

Description Peixiu Hou 2016-07-14 08:42:58 UTC
Created attachment 1179666 [details]
122SRLWIN2016 hlk package

Description of problem:

Windows guest BSOD w & w/o virtio-1.0 when run "DF - HyperVisor Code Integrity Readiness Test" job. Shown occurred error: DRIVER_VERIFIED_DETECTED_VIOLATION.

OS:
Win10-32/64
Win2016

Version-Release number of selected component (if applicable):
kernel-3.10.0-464.el7.x86_64
qemu-kvm-rhev-2.6.0-11.el7.x86_64
seabios-1.9.1-4.el7.x86_64
virtio-win-prewhql-122

How reproducible:
100%

Steps to Reproduce:
1.Boot guest with:
/usr/libexec/qemu-kvm -name 122SRLW10S646EN -enable-kvm -m 6G -smp 8 -uuid 9a5232cc-eee6-41bf-97f3-106bc022657b -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/122SRLW10S646EN,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=122SRLW10S646EN,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2016_technical_preview_5_x64_dvd_8512312.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=122RNGW10S646EN.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=00:52:47:3a:ba:b8,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:1 -vga cirrus -device virtio-serial-pci,id=serial0,bus=pci.0,addr=0x7,disable-legacy=on,disable-modern=off -chardev socket,id=serialchardev0,path=/tmp/122SRLW10DS646EN_port0,server,nowait -device virtserialport,id=port0,chardev=serialchardev0,bus=serial0.0

2.run whql test "DF - HyperVisor Code Integrity Readiness Test"


Actual results:
BSOD

Expected results:
Passed

Additional info:
Job passed w & w/o virtio-1.0 on virtio-win-prewhql-117  

Because this BSOD is deatructive,after BSOD occurred, restart the system, BSOD occurred again, so we cannot get the memory dump file.

HLK package file and BSOD picture as attachments.

Comment 1 Peixiu Hou 2016-07-14 08:44:54 UTC
Created attachment 1179667 [details]
BSOD on win2016

Comment 4 Peixiu Hou 2016-07-14 09:11:42 UTC
Hit same issue on viorng virtio-win-prewhql-122, run job "DF - HyperVisor Code Integrity Readiness Test", system occurred BSOD. --win10-32/64 & win2016

Comment 5 Gal Hammer 2016-07-18 13:25:56 UTC
The cause of this bug is in the virtiolib wdf which all wdf based drivers rely on.

*** This bug has been marked as a duplicate of bug 1356422 ***


Note You need to log in before you can comment on or make changes to this bug.