Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356465 - Docker can't be upgrade to 1.10.3 for containerized Openshift once set docker_version=1.10.3
Summary: Docker can't be upgrade to 1.10.3 for containerized Openshift once set docker...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade
Version: 3.2.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Devan Goodwin
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-14 08:04 UTC by Anping Li
Modified: 2016-09-06 19:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-06 19:46:30 UTC


Attachments (Terms of Use)

Description Anping Li 2016-07-14 08:04:02 UTC
Description of problem:
1) If set docker_version=1.10.3 and docker_upgrade=true, the upgrade failed with message "Cannot upgrade Docker to >= 1.10, please use the Docker upgrade playbook for this.".
2) Due to the latest Docker version is 1.10.3, we only set docker_ugprade=true, the upgrade success, and the Docker was upgraded to the latest (1.10.3).

1) & 2) should result same --Upgrade finished without errors.

Version-Release number of selected component (if applicable):
openshift/openshift-ansible: Pull Request 1945.

How reproducible:
always

Steps to Reproduce:
1)install openshift 3.2 with docker-1.9.1
2)docker_version=1.10.3 and docker_ugprade=true in inventory file
3)upgrade the containerized openshift 3.2

Actual results:

TASK: [docker | Error out if attempting to upgrade Docker across the 1.10 boundary] *** 
<host4master.example.com> ESTABLISH CONNECTION FOR USER: root
failed: [host4master.example.com] => {"failed": true}
msg: Cannot upgrade Docker to >= 1.10, please use the Docker upgrade playbook for this.

FATAL: all hosts have already failed -- aborting

PLAY RECAP ******************************************************************** 
           to retry, use: --limit @/root/upgrade.retry

host4master.example.com    : ok=46   changed=0    unreachable=0    failed=1   
host4node.example.com      : ok=28   changed=1    unreachable=0    failed=0   
localhost                  : ok=11   changed=0    unreachable=0    failed=0   



Expected results:
The upgrade succeed

Additional info:

Comment 1 Devan Goodwin 2016-07-14 17:10:42 UTC
Fixed in branch as of today.

Comment 2 Anping Li 2016-07-22 11:17:13 UTC
The bug fixed at atomic-openshift-utils-3.2.14-1


Note You need to log in before you can comment on or make changes to this bug.