Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356463 - The message isn't correct for containerized installation if docker 1.8.2 was pre-installed
Summary: The message isn't correct for containerized installation if docker 1.8.2 was ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.2.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Devan Goodwin
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-14 08:00 UTC by Anping Li
Modified: 2016-08-18 19:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
If Docker 1.8.2 is installed on a host before starting an OpenShift Enterprise 3.2 installation, Ansible now reports the following message: "Cannot upgrade Docker to >= 1.10, please upgrade or remove Docker manually, or use the Docker upgrade playbook if OpenShift is already installed."
Clone Of:
Environment:
Last Closed: 2016-08-18 19:28:48 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1639 normal SHIPPED_LIVE OpenShift Enterprise atomic-openshift-utils bug fix and enhancement update 2016-08-18 23:26:45 UTC

Comment 1 Devan Goodwin 2016-07-14 17:23:13 UTC
Wasn't able to reproduce this one either:

ansible OSEv3:children -i ./hosts -a "yum install -y 'docker-1.8.2'"

Inventory:
openshift_release=v3.2
containerized=true 

Result:

TASK: [docker | Error out if Docker pre-installed but too old] **************** 
failed: [m1.aos.example.com] => {"failed": true}
msg: Docker 1.8.2 is installed, but >= 1.9.1 is required.

Comment 2 Anping Li 2016-07-15 02:36:15 UTC
docker_version=1.10.3 was set.
For fresh install, we couldn't run Docker upgrade playbook. I think the message should be changed like 'Cannot upgrade Docker to >= 1.10, upgrade to Docker 1.10 mannuly.'

Comment 3 Devan Goodwin 2016-07-15 12:23:28 UTC
Message changing to: Cannot upgrade Docker to >= 1.10, please upgrade or remove Docker manually, or use the Docker upgrade playbook if OpenShift is already installed.

The same message needs to be used for both install, and re-running config.yml to maintain your environment. Ideally I'd like to avoid explicitly checking if OpenShift is installed inside this Docker role as it's a bit ill-placed and little logic forks like this are quite cumbersome with ansible. Sound ok to you Anping?

Comment 6 Anping Li 2016-08-09 04:43:55 UTC
Verified and pass atomic-openshift-utils-3.2.19

Comment 8 errata-xmlrpc 2016-08-18 19:28:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1639


Note You need to log in before you can comment on or make changes to this bug.