Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356453 - DHT: slow readdirp performance
Summary: DHT: slow readdirp performance
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Raghavendra G
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1356454 1457339 1457340 1457341
TreeView+ depends on / blocked
 
Reported: 2016-07-14 07:31 UTC by Sakshi
Modified: 2017-09-06 23:05 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1356454 1457339 1457340 1457341 (view as bug list)
Environment:
Last Closed: 2017-09-05 17:24:45 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sakshi 2016-07-14 07:31:39 UTC
Description of problem:
Under utilization of buffer provided by kernel during a readdirp request. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2016-07-14 09:00:50 UTC
REVIEW: http://review.gluster.org/12271 (dht: improving readdir[ performance) posted (#5) for review on master by Sakshi Bansal

Comment 4 Worker Ant 2016-12-13 11:36:19 UTC
REVIEW: http://review.gluster.org/12271 (dht: improving readdir performance) posted (#6) for review on master by Sakshi Bansal (sabansal@redhat.com)

Comment 5 Worker Ant 2017-03-01 17:27:35 UTC
REVIEW: https://review.gluster.org/12271 (cluster/dht: Make optimal usage of buffer provided with readdir(p)) posted (#11) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 6 Worker Ant 2017-03-01 17:34:52 UTC
REVIEW: https://review.gluster.org/12271 (cluster/dht: Make optimal usage of buffer provided with readdir(p)) posted (#12) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 7 Worker Ant 2017-03-02 09:06:51 UTC
REVIEW: https://review.gluster.org/16828 (cluster/dht: Make optimal usage of buffer provided with readdir(p)) posted (#1) for review on release-3.10 by Poornima G (pgurusid@redhat.com)

Comment 8 Worker Ant 2017-03-09 03:47:29 UTC
REVIEW: https://review.gluster.org/12271 (cluster/dht: Make optimal usage of buffer provided with readdir(p)) posted (#13) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 9 Worker Ant 2017-05-19 05:44:31 UTC
REVIEW: https://review.gluster.org/12271 (cluster/dht: Make optimal usage of buffer provided with readdir(p)) posted (#14) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 10 Worker Ant 2017-05-19 10:01:08 UTC
REVIEW: https://review.gluster.org/12271 (cluster/dht: Make optimal usage of buffer provided with readdir(p)) posted (#15) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 11 Worker Ant 2017-05-19 10:30:34 UTC
REVIEW: https://review.gluster.org/12271 (cluster/dht: Make optimal usage of buffer provided with readdir(p)) posted (#16) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 12 Worker Ant 2017-05-31 14:13:05 UTC
COMMIT: https://review.gluster.org/12271 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit b9406e210717621bc672a63c1cbd1b0183834056
Author: Sakshi <sabansal@redhat.com>
Date:   Mon Jan 23 12:11:49 2017 +0530

    cluster/dht: Make optimal usage of buffer provided with readdir(p)
    
    dht_readdirp must unwind with list of entries only after
    the entire buffer requested by kernel is filled to avoid
    extra syscalls occuring when returning partially filled
    buffer. Also wind readdir call to next subvol on reaching
    EOD for directory on that subvol to avoid extra network call.
    
    Change-Id: If2e1a2722f813d95457c7542bff25fef56c7a041
    BUG: 1356453
    Signed-off-by: Sakshi <sabansal@redhat.com>
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: https://review.gluster.org/12271
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Susant Palai <spalai@redhat.com>

Comment 13 Shyamsundar 2017-09-05 17:24:45 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 14 Csaba Henk 2017-09-06 06:07:11 UTC
*** Bug 1478411 has been marked as a duplicate of this bug. ***

Comment 15 nh2 2017-09-06 23:05:27 UTC
Note that bug https://bugzilla.redhat.com/show_bug.cgi?id=1478411#c6 which was marked as duplicate of this (I just unmarked it) is NOT fixed in Gluster 3.12, see the linked comment.


Note You need to log in before you can comment on or make changes to this bug.