Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356422 - [virtio-win][balloon][whql] Win10&2016 guest BSOD when run job "DF - HyperVisor Code Integrity Readiness Test"
Summary: [virtio-win][balloon][whql] Win10&2016 guest BSOD when run job "DF - HyperVis...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Gal Hammer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1356480 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-14 05:57 UTC by Peixiu Hou
Modified: 2017-01-06 07:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-06 07:00:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
122BLNWIN10-32 hlk package (deleted)
2016-07-14 06:03 UTC, Peixiu Hou
no flags Details
BSOD on win10-32 (deleted)
2016-07-14 06:04 UTC, Peixiu Hou
no flags Details

Description Peixiu Hou 2016-07-14 05:57:44 UTC
Description of problem:

Windows guest BSOD w & w/o virtio-1.0 when run "DF - HyperVisor Code Integrity Readiness Test" job. Shown occurred error: DRIVER_VERIFIED_DETECTED_VIOLATION.

OS:
Win10-32/64
Win2016

Version-Release number of selected component (if applicable):
kernel-3.10.0-464.el7.x86_64
qemu-kvm-rhev-2.6.0-11.el7.x86_64
seabios-1.9.1-4.el7.x86_64
virtio-win-prewhql-122

How reproducible:
100%

Steps to Reproduce:
1.Boot guest with:
/usr/libexec/qemu-kvm -name 122BLNW10D640F8 -enable-kvm -m 3G -smp 4 -uuid ae6aebff-7749-4825-a3a4-941574705d40 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/122BLNW10D640F8,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=122BLNW10D640F8,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_10_enterprise_x64_dvd_6851151.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=122BLNW10D640F8.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=00:52:08:45:3b:d8,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:1 -vga cirrus -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7,disable-legacy=on,disable-modern=off

2.run whql test "DF - HyperVisor Code Integrity Readiness Test"


Actual results:
BSOD

Expected results:
Passed

Additional info:
Job passed w & w/o virtio-1.0 on virtio-win-prewhql-117  

Because this BSOD is deatructive,after BSOD occurred, restart the system, BSOD occurred again, so we cannot get the memory dump file.

HLK package file and BSOD picture as attachments.

Comment 1 Peixiu Hou 2016-07-14 06:03:39 UTC
Created attachment 1179601 [details]
122BLNWIN10-32 hlk package

Comment 2 Peixiu Hou 2016-07-14 06:04:29 UTC
Created attachment 1179602 [details]
BSOD on win10-32

Comment 5 Gal Hammer 2016-07-17 14:20:00 UTC
This is a verifier crash caused when the option "code integrity checks" is enabled.

A patch was posted.

Comment 6 lijin 2016-07-18 03:07:04 UTC
Hi Gal,

QE found there is no WdfCoInstaller01011.dll file in Win10/x86 and Win10/amd64 folder,is this issue same with this bug?

If not,we will open a new to track it.

Thanks.

Comment 7 Gal Hammer 2016-07-18 07:27:35 UTC
(In reply to lijin from comment #6)
> Hi Gal,
> 
> QE found there is no WdfCoInstaller01011.dll file in Win10/x86 and
> Win10/amd64 folder,is this issue same with this bug?
> 
> If not,we will open a new to track it.
> 
> Thanks.

I don't think the WdfCoInstaller is required for Windows 10. It is already included in the default installation.

If I'm wrong and it is impossible to install the driver in Windows 10 please open a new bug.

Comment 8 lijin 2016-07-18 07:34:31 UTC
(In reply to Gal Hammer from comment #7)
> (In reply to lijin from comment #6)
> > Hi Gal,
> > 
> > QE found there is no WdfCoInstaller01011.dll file in Win10/x86 and
> > Win10/amd64 folder,is this issue same with this bug?
> > 
> > If not,we will open a new to track it.
> > 
> > Thanks.
> 
> I don't think the WdfCoInstaller is required for Windows 10. It is already
> included in the default installation.

Got it,thanks Gal:)

> If I'm wrong and it is impossible to install the driver in Windows 10 please
> open a new bug.

drivers can installed correctly on win10 and win2016,thanks again.

Comment 9 Gal Hammer 2016-07-18 13:25:56 UTC
*** Bug 1356480 has been marked as a duplicate of this bug. ***

Comment 10 lijin 2016-08-01 02:48:56 UTC
job "DF - HyperVisor Code Integrity Readiness Test" passed on all guest with build 123,so this issue has been fixed already,thanks.

Change status to verified.

Comment 11 lijin 2017-01-06 07:00:13 UTC
close as this issue has already been fixed in rhel7.3 virtio-win package


Note You need to log in before you can comment on or make changes to this bug.