Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356383 - SSH authentication for gluster servers no longer using the gnome prompt for password.
Summary: SSH authentication for gluster servers no longer using the gnome prompt for p...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-14 03:20 UTC by Nigel Babu
Modified: 2016-08-02 04:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-02 04:01:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nigel Babu 2016-07-14 03:20:37 UTC
I've noticed this in the logs

debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic,password
debug1: Next authentication method: gssapi-keyex
debug1: No valid Key exchange context
debug1: Next authentication method: gssapi-with-mic
debug1: Unspecified GSS failure.  Minor code may provide more information
Server krbtgt/GLUSTER.ORG@REDHAT.COM not found in Kerberos database

debug1: Unspecified GSS failure.  Minor code may provide more information
Server krbtgt/GLUSTER.ORG@REDHAT.COM not found in Kerberos database

debug1: Unspecified GSS failure.  Minor code may provide more information


debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic,password
debug1: Next authentication method: publickey


Is this because of freeipa? Considering it's no longer required, can we turn it off?

Comment 1 M. Scherer 2016-07-14 10:50:58 UTC
That's not a very helpful bug report. You do not tell what you do or how you do that, or what logs do trigger this. 


And no, we will not turn freeipa off.

Comment 2 Nigel Babu 2016-07-14 11:05:43 UTC
All I did was `ssh root@formicary.gluster.org`. To get this logs though, I did `ssh -v root@formicary.gluster.org`.

Comment 3 M. Scherer 2016-07-14 15:15:29 UTC
Well, the log is harmless so I am inclined to keep it this way, unless this result in a slowdown or a problem ?

Comment 4 Nigel Babu 2016-08-02 04:01:23 UTC
This works fine now. I think it was a problem on my computer?


Note You need to log in before you can comment on or make changes to this bug.