Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356363 - [virtio-win][viorng] cannot install viorng driver on win2008-32/64 (build 122)
Summary: [virtio-win][viorng] cannot install viorng driver on win2008-32/64 (build 122)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Ladi Prosek
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-14 02:20 UTC by Yu Wang
Modified: 2016-11-04 08:55 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2016-11-04 08:55:16 UTC


Attachments (Terms of Use)
install_error_screenshot (deleted)
2016-07-14 02:20 UTC, Yu Wang
no flags Details
setupapi.dev.log (deleted)
2016-07-18 07:58 UTC, Yu Wang
no flags Details
setupapi.dev.log (deleted)
2016-07-27 03:00 UTC, Peixiu Hou
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description Yu Wang 2016-07-14 02:20:44 UTC
Created attachment 1179558 [details]
install_error_screenshot

Description of problem:
cannot install viorng driver on win2008-32/64

Version-Release number of selected component (if applicable):
virtio-win-prewhql-122

How reproducible:
100%

Steps to Reproduce:
1.boot w/ rng device
2.install viorng driver on win2008-32 or win2008-64
3.

Actual results:
install failed(code 39)

Expected results:
install successfully

Additional info:
1 it is ok for build 117
2 both win2008-32 and win2008-64 hit this issue
3 both w/ virtio-1.0 and w/o virtio-1.0 device hit this issue

Comment 3 Gal Hammer 2016-07-18 07:36:21 UTC
Can you please attach the driver installation log: C:\Windows\inf\setupapi.dev.log

Comment 4 Yu Wang 2016-07-18 07:58:54 UTC
Created attachment 1180944 [details]
setupapi.dev.log

Hi Gal,

setupapi.dev.log as the attachment

Comment 5 Gal Hammer 2016-07-18 13:30:44 UTC
Ladi posted a patch.

Comment 7 Peixiu Hou 2016-07-26 09:25:36 UTC
Verified this bug with virtio-win-prewhql-123

Steps as comment#0

On win2008-32, viorng driver can be installed successfully.
On Win2008-64, remain occurred this issue w/ and w/o virtio-1.0 device, viorng driver cannot be installed, report error code 39. 


Best Regards~
Peixiu Hou

Comment 8 Ladi Prosek 2016-07-26 09:42:54 UTC
(In reply to Peixiu Hou from comment #7)
> Verified this bug with virtio-win-prewhql-123
> 
> Steps as comment#0
> 
> On win2008-32, viorng driver can be installed successfully.
> On Win2008-64, remain occurred this issue w/ and w/o virtio-1.0 device,
> viorng driver cannot be installed, report error code 39. 

So the driver still won't install on Win2008-64? Would it be possible to get access to the system?

Thanks!
Ladi

Comment 9 Gal Hammer 2016-07-26 11:42:19 UTC
In addition to comment #8. Can you please also attach the driver installation log: C:\Windows\inf\setupapi.dev.log from the Win2008-64 machine? Thanks.

Comment 10 Peixiu Hou 2016-07-27 03:00:59 UTC
Created attachment 1184482 [details]
setupapi.dev.log

Hi Ladi, Gal,

You can access to this system via remote-viewer vnc://10.73.72.4:5901
host ip: 10.73.72.4, password: Assentor01

And the setupapi.dev.log as the attachment~


Best Regards~
Peixiu Hou

Comment 11 Ladi Prosek 2016-07-27 08:51:22 UTC
Thank you. I tried installing build 117 which made the system pick up KB970158 "Kernel-Mode Driver Framework version 1.9 update for Windows 2000, for Windows XP, for Windows Server 2003, for Windows Vista, and for Windows Server 2008". After that build 123 installed without any issues.

It looks like the .inf file has changed:

 [VirtRng_Wdf_CoInstaller_AddReg]
 HKR,,CoInstallers32,0x00010000, \
-	"WdfCoInstaller01009.dll,WdfCoInstaller", \
+ 	"WdfCoInstaller01009.dll,WdfCoInstaller"
-	"viorngci.dll,VirtRngCoInstaller"
+HKR,,CoInstallers32,0x00010000,"viorngci.dll,VirtRngCoInstaller"

It used to specify both the WDF coinstaller and the viorng coninstaller, now it writes the key twice which doesn't have the same effect.

Fix coming.

Comment 12 Yu Wang 2016-07-27 09:03:43 UTC
(In reply to Ladi Prosek from comment #11)
> Thank you. I tried installing build 117 which made the system pick up
> KB970158 "Kernel-Mode Driver Framework version 1.9 update for Windows 2000,
> for Windows XP, for Windows Server 2003, for Windows Vista, and for Windows
> Server 2008". After that build 123 installed without any issues.
> 
> It looks like the .inf file has changed:
> 
>  [VirtRng_Wdf_CoInstaller_AddReg]
>  HKR,,CoInstallers32,0x00010000, \
> -	"WdfCoInstaller01009.dll,WdfCoInstaller", \
> + 	"WdfCoInstaller01009.dll,WdfCoInstaller"
> -	"viorngci.dll,VirtRngCoInstaller"
> +HKR,,CoInstallers32,0x00010000,"viorngci.dll,VirtRngCoInstaller"
> 
> It used to specify both the WDF coinstaller and the viorng coninstaller, now
> it writes the key twice which doesn't have the same effect.
> 
> Fix coming.

Hi Ladi,

Great news, and thanks for your prompt reply.
I just clarify that the win2008-32 have the same problem as win2008-64,too.

Thanks
Yu Wang

Comment 13 Ladi Prosek 2016-07-27 09:15:19 UTC
(In reply to Yu Wang from comment #12)
> Great news, and thanks for your prompt reply.
> I just clarify that the win2008-32 have the same problem as win2008-64,too.

Yes, it depends on whether KB970158 is already installed on the system. If it's not, the driver will fail to install. There shouldn't be any difference between 32-bit and 64-bit Win2008 in this regard.

Comment 16 Peixiu Hou 2016-08-01 02:28:05 UTC
Verified this issue with virtio-win-prewhql-124.

Steps as comment#0

On win2008-32&64, viorng driver can be installed successfully w/ & w/o virtio1.0,
this bug is fixed, thanks so much~


Best Regards~
Peixiu Hou

Comment 17 lijin 2016-08-01 02:32:39 UTC
change status to verified according to comment#16

Comment 19 errata-xmlrpc 2016-11-04 08:55:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.