Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356311 - Installation: subsystem certs could have notAfter beyond CA signing cert in case of external or existing CA
Summary: Installation: subsystem certs could have notAfter beyond CA signing cert in c...
Keywords:
Status: CLOSED DUPLICATE of bug 1350983
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: RHCS Maintainers
QA Contact: Asha Akkiangady
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-14 00:12 UTC by Matthew Harmsen
Modified: 2016-07-14 00:17 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-14 00:17:01 UTC


Attachments (Terms of Use)

Description Matthew Harmsen 2016-07-14 00:12:02 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/pki/ticket/2389

It appears that the CAValidity constraint is not applied during installation.
As a consequence, the subsystem certs created per .profile's could have notAfter beyond that of the CA signing cert imported during "external" or "existing" CA.

Comment 1 Matthew Harmsen 2016-07-14 00:17:01 UTC
Filed in error -- there was a previous bug that was re-opened

*** This bug has been marked as a duplicate of bug 1350983 ***


Note You need to log in before you can comment on or make changes to this bug.