Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356299 - Service account in GCE Provider validates for spaces when it should not
Summary: Service account in GCE Provider validates for spaces when it should not
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: GA
: 5.7.0
Assignee: Aparna Karve
QA Contact: Shveta
URL:
Whiteboard: cloud:provider
Depends On:
Blocks: 1372760
TreeView+ depends on / blocked
 
Reported: 2016-07-13 22:38 UTC by Aparna Karve
Modified: 2017-01-04 12:57 UTC (History)
6 users (show)

Fixed In Version: 5.7.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1372760 (view as bug list)
Environment:
Last Closed: 2017-01-04 12:57:26 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0012 normal SHIPPED_LIVE CFME 5.7.0 bug fixes and enhancement update 2017-01-04 17:50:36 UTC

Description Aparna Karve 2016-07-13 22:38:38 UTC
Description of problem:Service account in GCE Provider validates for spaces when it should not


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Add a GCE Cloud Provider
2. Enter JSON in the Service Account input field
3. 

Actual results:
"Spaces are prohibited" validation message appears

Expected results:
Service Account should ignore spaces, since spaces are expected

Additional info:

Comment 2 Satoe Imaishi 2016-08-18 20:30:22 UTC
Aparna, can you add PR link that fixed this issue?

Comment 3 Aparna Karve 2016-08-18 21:00:26 UTC
Satoe, here's the PR link - https://github.com/ManageIQ/manageiq/pull/9796

Comment 6 Shveta 2016-09-19 18:17:25 UTC
Fixed.
Verified in 5.7.0.0.20160906172503_12f65cb

Comment 8 errata-xmlrpc 2017-01-04 12:57:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0012.html


Note You need to log in before you can comment on or make changes to this bug.