Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356203 - Hosted Engine and RHEV-H host appear and in Admin Portal with Incorrect Display Names.
Summary: Hosted Engine and RHEV-H host appear and in Admin Portal with Incorrect Displ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.6.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Simone Tiraboschi
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-13 16:41 UTC by Chris Paquin
Modified: 2016-07-25 15:44 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-25 14:48:34 UTC
oVirt Team: Integration


Attachments (Terms of Use)
HE Display Name (deleted)
2016-07-13 16:41 UTC, Chris Paquin
no flags Details
RHEV-M Display Name (deleted)
2016-07-13 16:42 UTC, Chris Paquin
no flags Details
answers.conf (deleted)
2016-07-13 16:43 UTC, Chris Paquin
no flags Details
HE Setup Log -1 (deleted)
2016-07-22 21:02 UTC, Chris Paquin
no flags Details
HE Setup Log -2 (deleted)
2016-07-22 21:02 UTC, Chris Paquin
no flags Details
HE-FQDN (deleted)
2016-07-22 21:04 UTC, Chris Paquin
no flags Details
HE-DISPLAY-NAME (deleted)
2016-07-22 21:06 UTC, Chris Paquin
no flags Details
rhev12.png (deleted)
2016-07-22 21:14 UTC, Chris Paquin
no flags Details
rhev13.png (deleted)
2016-07-22 21:17 UTC, Chris Paquin
no flags Details
ovirt-hosted-engine-setup-logs.tar (deleted)
2016-07-25 14:26 UTC, Chris Paquin
no flags Details
he00.png (deleted)
2016-07-25 15:17 UTC, Chris Paquin
no flags Details
he01.png (deleted)
2016-07-25 15:22 UTC, Chris Paquin
no flags Details
he100.png (deleted)
2016-07-25 15:24 UTC, Chris Paquin
no flags Details
he100 (deleted)
2016-07-25 15:25 UTC, Chris Paquin
no flags Details
he7.png (deleted)
2016-07-25 15:34 UTC, Chris Paquin
no flags Details

Description Chris Paquin 2016-07-13 16:41:38 UTC
Created attachment 1179341 [details]
HE Display Name

Description of problem: When deploying the HostedEngine via "hosted-engine --deploy" and cloud-init. Display name of the Hosted-Engine is incorrect, as is the display name of the first rhev-h node. They appear to be swapped

Version-Release number of selected component (if applicable):
3.6.1

How reproducible:
Run hosted-engine --deploy and run cloud-init as part of the install, manually answering cloud-init questions

Steps to Reproduce:
1. run hosted-engine --deploy with cloud-init
2  enter the FQDN of hosted-engine appliance and display name of HE appliance
3. Log into admin portal

Actual results:
Hypervisor node appears with display name that was entered as the display name of the hosted-engine
Hosted-engine deploys with display name Hosted-Engine, not the name entered during cloud-init


Expected results:
Hypervisor node deploys with correct display name equal to its display name
HE deploys with correct display name equal to the name entered when prompted to "Enter the name which will be used to identify this host inside the Administrator Portal" 


Additional info:
I've run through three install/deploys - all have same result. 

RHEV-H Hostname: prometheus.lab.localdomain
RHEV-M Hostname: rhev.lab.localdomain
RHEV-M entered display name: rhev.lab.localdomain

Comment 1 Chris Paquin 2016-07-13 16:42:29 UTC
Created attachment 1179342 [details]
RHEV-M Display Name

Comment 2 Chris Paquin 2016-07-13 16:43:12 UTC
Created attachment 1179343 [details]
answers.conf

Comment 3 Chris Paquin 2016-07-13 16:45:59 UTC
Note I am also running into this bug as well (https://bugzilla.redhat.com/show_bug.cgi?id=1269768). Although the BZ appears to state that this was an issue in 3.6 but should no longer be an issue in 3.6.1.

I am wondering if the issue with the hosted-engine not being assigned the correct display name could be related in any way.

Comment 4 Yaniv Lavi 2016-07-17 10:51:55 UTC
Can you have a look?

Comment 5 Yedidyah Bar David 2016-07-17 13:07:46 UTC
Please attach full sosreport (including engine and hosts). Thanks.

Comment 6 Simone Tiraboschi 2016-07-18 07:42:38 UTC
(In reply to Chris Paquin from comment #0)
> Actual results:
> Hypervisor node appears with display name that was entered as the display
> name of the hosted-engine
> Hosted-engine deploys with display name Hosted-Engine, not the name entered
> during cloud-init

The display name of the engine VM is hardcoded to 'HostedEngine' and hosted-engine-setup is not going to let the user customize it.
We just ask the display name of the host with something line 'Enter the name which will be used to identify this host inside the Administrator Portal [hosted_engine_1]:' so I suppose you simply replaced there 'hosted_engine_1' with 'rhev.lab.localdomain' generating a bit of confusion.
Could you please provide your hosted-engine-setup logs?

Comment 9 Yaniv Lavi 2016-07-21 08:08:54 UTC
Re-adding the needinfo until info is provided.

Comment 11 Simone Tiraboschi 2016-07-21 14:24:15 UTC
Ok, re-adding the needinfo until the log file is provided.

Comment 12 Chris Paquin 2016-07-22 21:02:26 UTC
Created attachment 1182955 [details]
HE Setup Log -1

Comment 13 Chris Paquin 2016-07-22 21:02:57 UTC
Created attachment 1182956 [details]
HE Setup Log -2

Comment 14 Chris Paquin 2016-07-22 21:04:14 UTC
Created attachment 1182957 [details]
HE-FQDN

Comment 15 Chris Paquin 2016-07-22 21:06:59 UTC
Created attachment 1182958 [details]
HE-DISPLAY-NAME

Comment 17 Chris Paquin 2016-07-22 21:14:35 UTC
Created attachment 1182959 [details]
rhev12.png

Comment 18 Chris Paquin 2016-07-22 21:17:46 UTC
Created attachment 1182960 [details]
rhev13.png

Comment 19 Chris Paquin 2016-07-22 21:20:27 UTC
I have attached additional screenshots and logs.

If the proper process was not followed, please advise on the proper process to accomplish the following. Very curious as to how I could have changed the HE display name to the hostname of the hypervisor. Please advise how to add RHEV-H portal with correct FQDN.

Comment 20 Simone Tiraboschi 2016-07-25 12:23:11 UTC
Chris, 
you attached the logs of engine setup that was executed on the engine VM.
To understand this issue we need instead the logs from hosted-engine-setup: you can find them in /var/log/ovirt-hosted-engine-setup/ on the first physical host where you deploy your hosted-engine.

Comment 21 Chris Paquin 2016-07-25 14:26:48 UTC
Created attachment 1183820 [details]
ovirt-hosted-engine-setup-logs.tar

Comment 22 Chris Paquin 2016-07-25 14:27:14 UTC
Sorry about that - please see attached 

ovirt-hosted-engine-setup-logs.tar

Comment 23 Simone Tiraboschi 2016-07-25 14:48:34 UTC
Ok, the issue is simply here:

2016-07-12 22:05:23 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 Please provide the FQDN you would like to use for the engine appliance.
2016-07-12 22:05:23 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 Note: This will be the FQDN of the engine VM you are now going to launch,
2016-07-12 22:05:23 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 it should not point to the base host or to any other existing machine.
2016-07-12 22:05:23 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 Engine VM FQDN: (leave it empty to skip):  []: 
2016-07-12 22:05:32 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:RECEIVE    rhev.lab.localdomain

...

2016-07-12 22:06:44 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:SEND                 Enter the name which will be used to identify this host inside the Administrator Portal [hosted_engine_1]: 
2016-07-12 22:06:55 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:219 DIALOG:RECEIVE    rhev.lab.localdomain

The setup asked the application name you want to use for your host proposing 'hosted_engine_1' and you entered 'rhev.lab.localdomain' which was the address of your engine VM.

Please use a different application name (the host address is fine) for your hosts.

Comment 24 Chris Paquin 2016-07-25 14:58:22 UTC
Two questions.

1. Can the FQDN of the HE not be the same as the Display Name of the FQDN?

2. How does this explain how the display name for the RHEV-H host ended up as rhev.lab.localdomain? See he9.png. If you note he10.png. The HostedEngine (FQDN of rhev.lab.localdomain) appears as having a Hypervisor host as rhev.lab.localdomain.

The rhev-h host is prometheus.lab.localdomain. The hypervisor never appeared in the Admin portal with the correct name. Rather, its display name was rhev.lab.localdomain. I had to manually change this in the Admin portal to correct.

Comment 25 Chris Paquin 2016-07-25 15:17:12 UTC
Created attachment 1183829 [details]
he00.png

Comment 26 Chris Paquin 2016-07-25 15:21:58 UTC
Please note that I have attempted to install a second hosted engine for the purpose of configuring HA on hypervisor node -- atlas.lab.localdomain. 2nd hypervisor node is added, also with incorrect display name. Display name of hypervisor is hosted_engine_2, not atlas.lab.localdomain

See hosted-engine --deploy below

[root@atlas ~]# hosted-engine --deploy
[ INFO  ] Stage: Initializing
[ INFO  ] Generating a temporary VNC password.
[ INFO  ] Stage: Environment setup
          Continuing will configure this host for serving as hypervisor and create a VM where you have to install the engine afterwards.
          Are you sure you want to continue? (Yes, No)[Yes]: Yes
          Configuration files: []
          Log file: /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20160725151029-3pcg23.log
          Version: otopi-1.4.1 (otopi-1.4.1-1.el7ev)
          It has been detected that this program is executed through an SSH connection without using screen.
          Continuing with the installation may lead to broken installation if the network connection fails.
          It is highly recommended to abort the installation and run it inside a screen session using command "screen".
          Do you want to continue anyway? (Yes, No)[No]: Yes
[ INFO  ] Hardware supports virtualization
[ INFO  ] Bridge ovirtmgmt already created
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ INFO  ] Stage: Environment customization
         
          --== STORAGE CONFIGURATION ==--
         
          During customization use CTRL-D to abort.
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs3, nfs4)[nfs3]:     
          Please specify the full shared storage connection path to use (example: host:/path): 10.1.0.55:/var/lib/exports/nfs/data
          The specified storage location already contains a data domain. Is this an additional host setup (Yes, No)[Yes]? Yes
[ INFO  ] Installing on additional host
          Please specify the Host ID [Must be integer, default: 2]: 2
         
          --== SYSTEM CONFIGURATION ==--
         
[WARNING] A configuration file must be supplied to deploy Hosted Engine on an additional host.
[ INFO  ] Answer file successfully loaded
         
          --== NETWORK CONFIGURATION ==--
         
[ INFO  ] Additional host deployment, firewall manager is 'iptables'
          The following CPU types are supported by this host:
          	 - model_Nehalem: Intel Nehalem Family
          	 - model_Penryn: Intel Penryn Family
          	 - model_Conroe: Intel Conroe Family
         
          --== HOSTED ENGINE CONFIGURATION ==--
         
          Enter the name which will be used to identify this host inside the Administrator Portal [hosted_engine_2]: 
          Enter 'admin@internal' user password that will be used for accessing the Administrator Portal: 
          Confirm 'admin@internal' user password: 
[ INFO  ] Stage: Setup validation
[WARNING] Cannot validate host name settings, reason: resolved host does not match any of the local addresses
         
          --== CONFIGURATION PREVIEW ==--
         
          Engine FQDN                        : rhev.lab.localdomain
          Bridge name                        : ovirtmgmt
          Host address                       : atlas.lab.localdomain
          SSH daemon port                    : 22
          Firewall manager                   : iptables
          Gateway address                    : 10.1.0.1
          Host name for web application      : hosted_engine_2
          Storage Domain type                : nfs3
          Host ID                            : 2
          Image size GB                      : 50
          GlusterFS Share Name               : hosted_engine_glusterfs
          GlusterFS Brick Provisioning       : False
          Storage connection                 : 10.1.0.55:/var/lib/exports/nfs/data
          Console type                       : vnc
          Memory size MB                     : 8192
          MAC address                        : 00:16:3e:26:19:6c
          Boot type                          : disk
          Number of CPUs                     : 2
          Restart engine VM after engine-setup: True
          CPU Type                           : model_Nehalem
[ INFO  ] Stage: Transaction setup
[ INFO  ] Stage: Misc configuration
[ INFO  ] Stage: Package installation
[ INFO  ] Stage: Misc configuration
[ INFO  ] Configuring libvirt
[ INFO  ] Configuring VDSM
[ INFO  ] Starting vdsmd
[ INFO  ] Waiting for VDSM hardware info
[ INFO  ] Waiting for VDSM hardware info
[ INFO  ] Waiting for VDSM hardware info
[ INFO  ] Waiting for VDSM hardware info
[ INFO  ] Configuring VM
[ INFO  ] Updating hosted-engine configuration
[ INFO  ] Stage: Transaction commit
[ INFO  ] Stage: Closing up
[ INFO  ] Acquiring internal CA cert from the engine
[ INFO  ] The following CA certificate is going to be used, please immediately interrupt if not correct:
[ INFO  ] Issuer: C=US, O=lab.localdomain, CN=rhev.lab.localdomain.29215, Subject: C=US, O=lab.localdomain, CN=rhev.lab.localdomain.29215, Fingerprint (SHA-1): BF70FEC36D7CFCED041EF5C592BE941D829AEC85
[ INFO  ] Connecting to the Engine
[ INFO  ] Waiting for the host to become operational in the engine. This may take several minutes...
[ INFO  ] Still waiting for VDSM host to become operational...
[ INFO  ] The VDSM Host is now operational
[ INFO  ] Enabling and starting HA services
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20160725151334.conf'
[ INFO  ] Generating answer file '/etc/ovirt-hosted-engine/answers.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ INFO  ] Hosted Engine successfully set up

Now Admin portal shows second hypervisor node. However display name is incorrect. See attached screenshot he00.png.

Hosted_Engine_2 does not appear in the list of virtual Machines. See he01.png

Comment 27 Chris Paquin 2016-07-25 15:22:38 UTC
Created attachment 1183831 [details]
he01.png

Comment 28 Chris Paquin 2016-07-25 15:24:28 UTC
Created attachment 1183832 [details]
he100.png

Comment 29 Chris Paquin 2016-07-25 15:25:23 UTC
Created attachment 1183833 [details]
he100

Comment 30 Simone Tiraboschi 2016-07-25 15:25:39 UTC
You cannot choose the display name of the engine VM which is always hosted_engine(In reply to Chris Paquin from comment #24)
> Two questions.
> 
> 1. Can the FQDN of the HE not be the same as the Display Name of the FQDN?

You cannot change the display name of the engine VM: it requires to be HostedEngine cause the engine has to identify it somehow since it's a special VM.
You can use any vali FDQN as its FQDN.

> 2. How does this explain how the display name for the RHEV-H host ended up
> as rhev.lab.localdomain? See he9.png. If you note he10.png. The HostedEngine
> (FQDN of rhev.lab.localdomain) appears as having a Hypervisor host as
> rhev.lab.localdomain.

You explicitly chose that:
 Enter the name which will be used to identify this host inside the Administrator Portal [hosted_engine_1]: rhev.lab.localdomain

hosted-engine-setup and the engine let you write any string here including the fqdn of another machine as you did.

> The rhev-h host is prometheus.lab.localdomain. The hypervisor never appeared
> in the Admin portal with the correct name. Rather, its display name was
> rhev.lab.localdomain. I had to manually change this in the Admin portal to
> correct.

Comment 31 Simone Tiraboschi 2016-07-25 15:27:53 UTC
(In reply to Chris Paquin from comment #26)
> Please note that I have attempted to install a second hosted engine for the
> purpose of configuring HA on hypervisor node -- atlas.lab.localdomain. 2nd
> hypervisor node is added, also with incorrect display name. Display name of
> hypervisor is hosted_engine_2, not atlas.lab.localdomain
...
>           Enter the name which will be used to identify this host inside the
> Administrator Portal [hosted_engine_2]: 

The setup proposed 'hosted_engine_2', you accepted and so you got 'hosted_engine_2'

In the future we will propose the host fqdn as the default here.

Comment 32 Chris Paquin 2016-07-25 15:34:50 UTC
Created attachment 1183852 [details]
he7.png

Comment 33 Chris Paquin 2016-07-25 15:41:16 UTC
Ah I see. So hosted_engine1 and hosted_engine2 are the default display names of the hypervisor.

Thanks for the explanation. As you can tell this is very confusing. Glad to hear this is going to be changed in the future.

For reference, see he7.png.

Under the section 

--==Hosted Engine Configuration==--

You are asked to 

"Enter the name which will be used to identify this host inside the Administrator Portal [hosted_engine_1]

Since this question is being asked during the configuration section of the hosted-engine, one would assume that this question is asking for the display name of the hosted-engine VM, and not the underlying hypervisor host.


One last question, after I delete my hosted engine, is there a way to restore the hypervisor node back to its clean, post-initial installation state? I would like to run through the process again, but without re-installing RHEV-H.

Thanks again.

Comment 34 Simone Tiraboschi 2016-07-25 15:44:55 UTC
(In reply to Chris Paquin from comment #33)
> One last question, after I delete my hosted engine, is there a way to
> restore the hypervisor node back to its clean, post-initial installation
> state? I would like to run through the process again, but without
> re-installing RHEV-H.

No, there is not.
You can simply try reusing it but if it's going to be pushed to production I'd advise to restart from scratch.


Note You need to log in before you can comment on or make changes to this bug.