Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356177 - [RFE] Allow the exporting of puppet modules from content views as part of ISS
Summary: [RFE] Allow the exporting of puppet modules from content views as part of ISS
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
: 1370597 (view as bug list)
Depends On:
Blocks: 1285244
TreeView+ depends on / blocked
 
Reported: 2016-07-13 15:03 UTC by Chris Duryee
Modified: 2018-09-25 14:44 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 19:21:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 16823 None None None 2016-10-06 15:15:50 UTC

Description Chris Duryee 2016-07-13 15:03:30 UTC
Description of problem:

If you use the "hammer content-view version export" command and attempt to export a CV containing only a puppet repo and nothing else, you'll get an error.

See https://bugzilla.redhat.com/show_bug.cgi?id=1285244#c98

"""
I just updated to Snap 20.0 
I created new CV with some Errata RPMs and one Puppet module, published, and the export worked OK.


Then, just for fun, I created another CV with just a Puppet module, published that, ran the export command:

[Foreman] Password for admin: 
[..........] [50%]
Error: unknown file type: /var/lib/pulp/published/yum/master/group_export_distributor/Default_Organization-TestViewPuppetOnly-v1.0
[root@rhel7-2-sat6-2 ~]# 

as I have self made modules I changed to anther module but still got error:
[Foreman] Password for admin: 
[............................] [100%]
Error: unknown file type: /var/lib/pulp/published/yum/master/group_export_distributor/Default_Organization-TestViewPuppetOnly-v2.0
[root@rhel7-2-sat6-2 ~]# 

"""

Version-Release number of selected component (if applicable): snap 20.0

Comment 3 Bryan Kearney 2016-10-06 16:11:39 UTC
Upstream bug component is Content Management

Comment 4 anerurka 2017-06-08 06:29:10 UTC
Currently if a content view is having puppet module, then puppet modules are not exported from the Satellite Server.

The same has been mentioned [1] stating that it is not supported.

So can this be considered in this Bugzilla or do we need to have a another Bugzilla to ensure that puppet modules are also exported while exporting content view ?

[1] https://access.redhat.com/documentation/en-us/red_hat_satellite/6.2/html-single/content_management_guide/#Using_ISS

Regards,
Ameya Nerurkar

Comment 5 Bryan Kearney 2017-09-07 16:36:18 UTC
*** Bug 1406262 has been marked as a duplicate of this bug. ***

Comment 6 Bryan Kearney 2017-09-07 16:36:42 UTC
*** Bug 1370597 has been marked as a duplicate of this bug. ***

Comment 7 Bryan Kearney 2018-09-04 19:21:30 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.