Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356173 - kickstart.profile.set_advanced_options does not update kickstart file
Summary: kickstart.profile.set_advanced_options does not update kickstart file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning
Version: 570
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Jiří Dostál
QA Contact: Pavel Studeník
URL:
Whiteboard:
Depends On:
Blocks: sat5-errata
TreeView+ depends on / blocked
 
Reported: 2016-07-13 14:51 UTC by Patrik Segedy
Modified: 2016-11-07 13:38 UTC (History)
4 users (show)

Fixed In Version: spacewalk-java-2.3.8-154-sat
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 13:38:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2662 normal SHIPPED_LIVE Satellite 5.7 bug fix update 2016-11-07 18:37:17 UTC

Description Patrik Segedy 2016-07-13 14:51:53 UTC
Description of problem:
kickstart.profile.set_advanced_options does not update kickstart file, when url option argument is set without server hostname (like --url /ks/dist/ks-rhel-x86_64-server-6-6.4)

Version-Release number of selected component (if applicable):
spacewalk-java-2.3.8-142.el6sat.noarch
cobbler-2.0.7-66.el6sat.noarch


How reproducible:
100%

Steps to Reproduce:
1. Create kickstart profile named test-kickstart
2.
# Modify advanced options
KS_LABEL = "test-kickstart"
new_advopt_arr = []
for option in client.kickstart.profile.get_advanced_options(key, KS_LABEL):
    if option['name'] == 'url':
        new_advopt_arr.append({'name': 'url', 'arguments': '--url /ks/dist/' +
                               'ks-rhel-x86_64-server-6-6.8'})
    else:
        new_advopt_arr.append(option)

client.kickstart.profile.set_advanced_options(key, KS_LABEL, new_advopt_arr)

3.
# Check output of kickstart.profile.getAdvancedOptions
spacewalk-api --server=localhost --user=admin --password=nimda kickstart.profile.getAdvancedOptions "%session%" test-kickstart | 
    perl -le 'undef$/;eval<>;$_->{'name'}eq 'url'&&print$_->{'arguments'}for@$result' | rev | cut -d/ -f 1 | rev

// output
ks-rhel-x86_64-server-6-6.8

-------

# Check cobbler 
cobbler profile getks --name=test-kickstart:1:RedHatSatTeamQA | grep ^url | rev | cut -d/ -f 1 | rev

// output
ks-rhel-x86_64-server-6-6.0


Same old value is in System -> Kickstart -> Profiles -> test-kickstart -> Kickstart File

Actual results:
Kickstart file is not updated

Expected results:
Kickstart file should contain updated url

Additional info:
It doesn't update Kickstart file even when using web ui

Comment 1 Tomas Lestach 2016-07-14 14:00:40 UTC
I'd say, this has been fixed in upstream. We need to investigate.

Comment 2 Jiří Dostál 2016-07-28 08:23:41 UTC
spacewalk.git 03b5989d3f2aeb60b6c654b79368c96852c43efd

Comment 3 Jiří Dostál 2016-09-06 15:15:11 UTC
One more commit.
Spacewalk.git ba2130c8931235cf6eaacf71f60136f92202bbd8

Comment 6 Pavel Studeník 2016-10-06 12:54:02 UTC
Verified with spacewalk-java-2.3.8-154.el6sat.noarch

Reproducer is in Description

Comment 8 errata-xmlrpc 2016-11-07 13:38:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2662.html


Note You need to log in before you can comment on or make changes to this bug.