Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356144 - host-find should not print SSH keys by default, only SSH fingerprints
Summary: host-find should not print SSH keys by default, only SSH fingerprints
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-13 13:20 UTC by Petr Vobornik
Modified: 2016-11-04 05:58 UTC (History)
3 users (show)

Fixed In Version: ipa-4.4.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 05:58:19 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Petr Vobornik 2016-07-13 13:20:40 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/6043


{{{
ipa host-find
  Host name: vm-058-188.abc.idm.lab.eng.brq.redhat.com
  Principal name: host/vm-058-188.abc.idm.lab.eng.brq.redhat.com@DOM-012.ABC.IDM.LAB.ENG.BRQ.REDHAT.COM
  SSH public key: ssh-rsa
                  AAAAB3NzaC1yc2EAAAADAQABAAABAQDFgu7eJYeuiGwVmn3oLZosisD0wZ+lGL7rnvqMCYu3M8/xCvFtSy/i6t6U1gmg78rvidfStGWfv9iuUMW5kjcfTbiBQFiz+ibht10u0mJTLlTOY3p+llOOKjyxwMmHdCJ2B4k6c3A1T+0iSo5JUyVHTSULjec7+r93K8XPtmnYQbxtjonP3VXTmjALYl4QxiJ7RLSYoJc9eLzw+HapJQSTqqs+VnKpy8DV/BJLnL+ZgmuTuL40+1VNEAv4ruMOHjQZAMvj7ZSZGyDHec6nqbij2IJMfZzOEOavzMrWdWxeWFe214NQoNWWk6M3tZSmb/B3Yhl3xqvrysIFkoj8pAPl,
                  ecdsa-sha2-nistp256 AAAAE2VjZHNhLXNoYTItbmlzdHAyNTYAAAAIbmlzdHAyNTYAAABBBCFmaNF74NunGg6rJPfNhSaHofmzlA12zJg69FJpW8imWtswbgLEx8OYtIX9dDIkryhnoGq5Grp/DDHbHSuahAU=, ssh-ed25519
                  AAAAC3NzaC1lZDI1NTE5AAAAIEmnjnW0uFee4iXegZrLHlVCh5pyD8xZbQkg6p+dP2VW
}}}

Regression caused by commit 14ee02dcbd6cbb6c221ac7526e471a9fc58fcc82

Comment 1 Petr Vobornik 2016-07-13 16:39:28 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/2874fdbfef1e191cf858dabdd34d5a0cbdc5ef16

Comment 3 Pavel Picka 2016-09-21 07:02:10 UTC
Verified - 4.4.0-12

{{

ipa host-find
--------------
1 host matched
--------------
  Host name: rhel06.testrelm.test
  Principal name: host/rhel06.testrelm.test@TESTRELM.TEST
  Principal alias: host/rhel06.testrelm.test@TESTRELM.TEST
  SSH public key fingerprint: 20:42:35:8D:07:A9:7E:C9:53:EA:99:5A:94:7D:92:12 (ssh-rsa),
                              80:B8:C9:64:B4:1C:D6:C8:DE:E1:F0:4B:81:CC:9C:5B (ssh-ed25519),
                              BB:77:49:95:32:F1:89:54:E0:92:8E:81:57:10:87:17 (ecdsa-sha2-nistp256)
----------------------------
Number of entries returned 1
----------------------------

}}

Comment 5 errata-xmlrpc 2016-11-04 05:58:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.