Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356142 - host-find, host-show do not show ssh fingerprint by default
Summary: host-find, host-show do not show ssh fingerprint by default
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-13 13:19 UTC by Petr Vobornik
Modified: 2016-07-20 15:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-20 15:26:57 UTC


Attachments (Terms of Use)

Description Petr Vobornik 2016-07-13 13:19:05 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/6042

It is expected that in output of host-find and host-show the fingerprint of all SSH keys should be shown.

Got:
{{{
ipa host-show vm-058-188.abc.idm.lab.eng.brq.redhat.com
  Host name: vm-058-188.abc.idm.lab.eng.brq.redhat.com
  Principal name: host/vm-058-188.abc.idm.lab.eng.brq.redhat.com@DOM-012.ABC.IDM.LAB.ENG.BRQ.REDHAT.COM
  Password: False
  Member of host-groups: ipaservers
  Keytab: True
  Managed by: vm-058-188.abc.idm.lab.eng.brq.redhat.com
}}}

Expected:
{{{
ipa host-show vm-058-188.abc.idm.lab.eng.brq.redhat.com
  Host name: vm-058-188.abc.idm.lab.eng.brq.redhat.com
  Principal name: host/vm-058-188.abc.idm.lab.eng.brq.redhat.com@DOM-012.ABC.IDM.LAB.ENG.BRQ.REDHAT.COM
  Password: False
  Member of host-groups: ipaservers
  Keytab: True
  Managed by: vm-058-188.abc.idm.lab.eng.brq.redhat.com
  SSH fingerprint: B5:AE:22:61:9A:2E:B3:11:15:35:8C:90:60:FE:78:49 (ssh-rsa), E0:A7:72:95:43:93:22:91:B2:E6:F9:7D:B1:22:9B:7F (ecdsa-sha2-nistp256), 3A:C5:EC:89:FE:C2:46:7B:D3:9D:92:9F:CC:BC:61:EA (ssh-ed25519)
}}}

Actually API call returns fingeprints, only on client side they are not shown.
{{{
    "result": {
        "result": {
            "dn": "fqdn=vm-058-188.abc.idm.lab.eng.brq.redhat.com,cn=computers,cn=accounts,dc=dom-012,dc=abc,dc=idm,dc=lab,dc=eng,dc=brq,dc=redhat,dc=com", 
            "fqdn": [
                "vm-058-188.abc.idm.lab.eng.brq.redhat.com"
            ], 
            "has_keytab": true, 
            "has_password": false, 
            "krbprincipalname": [
                "host/vm-058-188.abc.idm.lab.eng.brq.redhat.com@DOM-012.ABC.IDM.LAB.ENG.BRQ.REDHAT.COM"
            ], 
            "managedby_host": [
                "vm-058-188.abc.idm.lab.eng.brq.redhat.com"
            ], 
            "memberof_hostgroup": [
                "ipaservers"
            ], 
            "sshpubkeyfp": [
                "B5:AE:22:61:9A:2E:B3:11:15:35:8C:90:60:FE:78:49 (ssh-rsa)", 
                "E0:A7:72:95:43:93:22:91:B2:E6:F9:7D:B1:22:9B:7F (ecdsa-sha2-nistp256)", 
                "3A:C5:EC:89:FE:C2:46:7B:D3:9D:92:9F:CC:BC:61:EA (ssh-ed25519)"
            ]
        }, 
        "summary": null, 
        "value": "vm-058-188.abc.idm.lab.eng.brq.redhat.com"
}}}

Probably caused by think client feature.

Comment 1 Martin Bašti 2016-07-20 15:26:57 UTC
I cannot reproduce this anymore


Note You need to log in before you can comment on or make changes to this bug.