Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356088 - python-lib389 is missing in rhel7
Summary: python-lib389 is missing in rhel7
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base
Version: 7.3
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Noriko Hosoi
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-13 11:43 UTC by Sankar Ramalingam
Modified: 2017-09-05 14:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-02 16:53:07 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sankar Ramalingam 2016-07-13 11:43:50 UTC
Description of problem: Installation of 389-ds-base-tests package fails since python-lib389 package not added in RHEL7.


Version-Release number of selected component (if applicable): 389-ds-base-1.3.5.10-3


How reproducible:


Steps to Reproduce:
1. Install 389-ds-base, 389-ds-base-tests and its dep components in rhel7.3
2. Brew link - https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=502959
3. Installation of 389-ds-base-tests fail with python-lib389 package not found.

It fails in the CI environment...

07:21:32 --> Processing Dependency: python-lib389 for package: 389-ds-base-tests-1.3.5.10-3.el7.noarch
07:21:32 --> Finished Dependency Resolution
07:21:32  You could try using --skip-broken to work around the problem
07:21:32 Error: Package: 389-ds-base-tests-1.3.5.10-3.el7.noarch (brew-task-11333149-noarch)
07:21:32            Requires: python-lib389

Actual results: Jenkins job fails.


Expected results: Add this package in rhel7. Jenkins job should be successful.


Additional info:

Comment 4 Noriko Hosoi 2016-11-04 18:14:11 UTC
Upstream ticket:
https://fedorahosted.org/389/ticket/49032

Comment 5 Nathan Kinder 2016-12-02 16:53:07 UTC
We don't have anything that requires lib389 yet, so we shouldn't include it in RHEL 7.4.  Closing as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.