Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356080 - QCI 1.2: RHEV - machine becomes unavailable when selected in different Setup Type
Summary: QCI 1.2: RHEV - machine becomes unavailable when selected in different Setup ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHEV
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 1.0
Assignee: Erik Nelson
QA Contact: bmorriso
Dan Macpherson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-13 11:24 UTC by Antonin Pagac
Modified: 2016-09-13 16:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:31:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description Antonin Pagac 2016-07-13 11:24:50 UTC
Description of problem:
When configuring the deployment of RHEV, if a machine is chosen as an engine in Hypervisor + engine Setup Type, it becomes unavailable for Self-hosted Setup Type.

Example: User wants to deploy RHEV. He has Machine1 and Machine2 discovered and available. During the deployment configuration, in RHEV step '2A. Setup Type', he chooses 'Hypervisor + engine' and next in step 2B he chooses Machine1 to be an engine. Suddenly, he changes his mind and decides he wants a self-hosted setup with two hypervisors. So he goes back to step '2A. Setup Type' and chooses 'Self-hosted'. In step '2B. Engine/Hypervisor' he sees only Machine2, but he expects to see both Machine1 and Machine2.

Workaround is to delete this deployment, start a new one and choose desired Setup Type at first try. I can't un-select the engine machine at this time.

Version-Release number of selected component (if applicable):
20160711.t.1

How reproducible:
Always

Steps to Reproduce:
1. During configuration of RHEV deployment, choose hypervisor+engine setup type
2. Choose an engine machine
3. Go back, change to self-hosted setup type
4. in the next step, the machine you have selected as an engine is not displayed as available

Actual results:
The machine chosen in different setup type isn't listed as available in the current setup type

Expected results:
All machines should be listed as available when I change setup type

Additional info:

Comment 4 Erik Nelson 2016-07-20 19:21:40 UTC
PR: https://github.com/fusor/fusor/pull/1071

Comment 11 John Matthews 2016-07-25 12:40:29 UTC
QCI-1.0-RHEL-7-20160723.t.0-QCI-x86_64-dvd1.iso

Comment 12 bmorriso 2016-08-11 17:14:11 UTC
Verified in compose QCI-1.0-RHEL-7-20160809.t.1

Following reproduction steps in description:

I began with an Engine+Hypervisor deployment of RHEV and selected a machine to act as the Engine. Then, I went back a page and switched to a Self-hosted deployment. On the next page (2B. Engine/Hypervisor), all previously available discovered hosts were still available, as expected.

Comment 14 errata-xmlrpc 2016-09-13 16:31:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.