Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356077 - Error from DataBinding 'hiera' while looking up 'tripleo::packages::enable_install'
Summary: Error from DataBinding 'hiera' while looking up 'tripleo::packages::enable_in...
Keywords:
Status: CLOSED DUPLICATE of bug 1353079
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Emilien Macchi
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-13 11:22 UTC by Gonéri Le Bouder
Modified: 2016-07-13 12:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-13 12:02:10 UTC


Attachments (Terms of Use)

Description Gonéri Le Bouder 2016-07-13 11:22:47 UTC
Description of problem:

Hi all,

i'm using puddle 2016-07-11.1 of OSP and OSP-d and I get blocked by the following error:

messages:Jul 13 06:25:01 localhost os-collect-config: [2016-07-13 06:25:01,022] (heat-config) [DEBUG] Running /var/lib/heat-config/hooks/puppet < /var/lib/heat-config/deployed/51274b36-2c90-49f0-bd45-e6e6691cb640.json
messages:Jul 13 06:25:04 localhost os-collect-config: [2016-07-13 06:25:04,756] (heat-config) [DEBUG] [2016-07-13 06:25:01,053] (heat-config) [DEBUG] Running FACTER_heat_outputs_path="/var/run/heat-config/heat-config-puppet/51274b36-2c90-49f0-bd45-e6e6691cb640"  FACTER_fqdn="716182-lab2-controller01.localdomain"  FACTER_deploy_config_name="ControllerLoadBalancerDeployment_Step1"  puppet apply --detailed-exitcodes /var/lib/heat-config/heat-config-puppet/51274b36-2c90-49f0-bd45-e6e6691cb640.pp
messages:Jul 13 06:25:04 localhost os-collect-config: [2016-07-13 06:25:04,752] (heat-config) [ERROR] Error running /var/lib/heat-config/heat-config-puppet/51274b36-2c90-49f0-bd45-e6e6691cb640.pp. [1]
messages:Jul 13 06:25:04 localhost os-collect-config: [2016-07-13 06:25:04,756] (heat-config) [INFO] Completed /var/lib/heat-config/hooks/puppet

[root@716182-lab2-controller01 log]# puppet apply --detailed-exitcodes /var/lib/heat-config/heat-config-puppet/51274b36-2c90-49f0-bd45-e6e6691cb640.pp
Error: Error from DataBinding 'hiera' while looking up 'tripleo::packages::enable_install': (<unknown>): mapping values are not allowed in this context at line 331 column 42 on node 716182-lab2-controller01.localdomain
Wrapped exception:
(<unknown>): mapping values are not allowed in this context at line 331 column 42
Wrapped exception:
(<unknown>): mapping values are not allowed in this context at line 331 column 42
Error: Error from DataBinding 'hiera' while looking up 'tripleo::packages::enable_install': (<unknown>): mapping values are not allowed in this context at line 331 column 42 on node 716182-lab2-controller01.localdomain
[root@716182-lab2-controller01 log]# grep -r tripleo::packages::enable_install /etc/puppet/
/etc/puppet/hieradata/controller.yaml:tripleo::packages::enable_install: false


I used this command to deploy my cluster:
openstack overcloud deploy --stack lab2 --templates --ntp-server time.iad3.somewhere.com -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e /home/stack/templates/ids-hostnames.yaml -e /home/stack/templates/environments/network-environment.yaml -e /home/stack/templates/environments/storage-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/external-loadbalancer-vip.yaml -e /home/stack/templates/external-lb.yaml -e /home/stack/templates/enable-tls-f5.yaml -e /home/stack/templates/inject-trust-anchor-f5.yaml -e /home/stack/templates/wipe_disk_resource.yaml -e /home/stack/templates/raxconfig_resource.yaml -e /home/stack/templates/maas_resource.yaml --control-flavor control --compute-flavor compute --ceph-storage-flavor ceph-storage --neutron-network-type vxlan --neutron-tunnel-types vxlan --control-scale 3 --compute-scale 3 --ceph-storage-scale 4


Some more details:
[stack@directorvm ~]$ nova list
/usr/lib/python2.7/site-packages/requests/packages/urllib3/connection.py:303: SubjectAltNameWarning: Certificate for 172.22.216.102 has no `subjectAltName`, falling back to check for a `commonName` for now. This feature is being removed by major browsers and deprecated by RFC 2818. (See https://github.com/shazow/urllib3/issues/497 for details.)
  SubjectAltNameWarning
/usr/lib/python2.7/site-packages/requests/packages/urllib3/connection.py:303: SubjectAltNameWarning: Certificate for 172.22.216.102 has no `subjectAltName`, falling back to check for a `commonName` for now. This feature is being removed by major browsers and deprecated by RFC 2818. (See https://github.com/shazow/urllib3/issues/497 for details.)
  SubjectAltNameWarning
+--------------------------------------+--------------------------+--------+------------+-------------+-------------------------+
| ID                                   | Name                     | Status | Task State | Power State | Networks                |
+--------------------------------------+--------------------------+--------+------------+-------------+-------------------------+
| af8eb2a5-7c08-434a-8b5c-53b36960fd3c | 716182-lab2-controller01 | ACTIVE | -          | Running     | ctlplane=172.22.216.115 |
| 300439ae-9e4c-4e34-901e-bc6ad617eae5 | 716183-lab2-controller02 | ACTIVE | -          | Running     | ctlplane=172.22.216.113 |
| e5a3ce7c-f59e-44d9-a1ae-ba651997c938 | 716184-lab2-controller03 | ACTIVE | -          | Running     | ctlplane=172.22.216.116 |
| bc86f9ab-924d-4835-9462-d736577da24e | 716185-lab2-compute01    | ACTIVE | -          | Running     | ctlplane=172.22.216.112 |
| 519d241c-ff2c-4fda-8007-3c26a85c792a | 716186-lab2-compute02    | ACTIVE | -          | Running     | ctlplane=172.22.216.111 |
| a57aa5a1-518d-49b1-b68e-fc5965f0adac | 716187-lab2-compute03    | ACTIVE | -          | Running     | ctlplane=172.22.216.114 |
| 17d4f346-8faf-448c-9b93-380e673da191 | 716199-lab2-cephperf01   | ACTIVE | -          | Running     | ctlplane=172.22.216.108 |
| 14b4b675-103b-4023-9a39-91263b15830b | 716200-lab2-cephperf02   | ACTIVE | -          | Running     | ctlplane=172.22.216.107 |
| 5ae2d697-6b22-46fc-8053-305da6e94927 | 716201-lab2-cephcap01    | ACTIVE | -          | Running     | ctlplane=172.22.216.117 |
| 38f2c075-c3cd-4438-a160-c3439a8b93bc | 716202-lab2-cephcap02    | ACTIVE | -          | Running     | ctlplane=172.22.216.118 |
+--------------------------------------+--------------------------+--------+------------+-------------+-------------------------+
[stack@directorvm ~]$ ironic node-list
/usr/lib/python2.7/site-packages/requests/packages/urllib3/connection.py:303: SubjectAltNameWarning: Certificate for 172.22.216.102 has no `subjectAltName`, falling back to check for a `commonName` for now. This feature is being removed by major browsers and deprecated by RFC 2818. (See https://github.com/shazow/urllib3/issues/497 for details.)
  SubjectAltNameWarning
/usr/lib/python2.7/site-packages/requests/packages/urllib3/connection.py:303: SubjectAltNameWarning: Certificate for 172.22.216.102 has no `subjectAltName`, falling back to check for a `commonName` for now. This feature is being removed by major browsers and deprecated by RFC 2818. (See https://github.com/shazow/urllib3/issues/497 for details.)
  SubjectAltNameWarning
+--------------------------------------+------------------------------------------+--------------------------------------+-------------+--------------------+-------------+
| UUID                                 | Name                                     | Instance UUID                        | Power State | Provisioning State | Maintenance |
+--------------------------------------+------------------------------------------+--------------------------------------+-------------+--------------------+-------------+
| 65f3139c-d4bf-41fb-9f01-2e7e450bf1fc | 716182-lab2-controller.rpc.rackspace.com | af8eb2a5-7c08-434a-8b5c-53b36960fd3c | power on    | active             | False       |
| dbf28ecc-c399-47ec-bc50-0c87c9c1bfe2 | 716183-lab2-controller.rpc.rackspace.com | 300439ae-9e4c-4e34-901e-bc6ad617eae5 | power on    | active             | False       |
| ac3f0f23-44d5-49b8-9953-6a228a4cda0e | 716184-lab2-controller.rpc.rackspace.com | e5a3ce7c-f59e-44d9-a1ae-ba651997c938 | power on    | active             | False       |
| 0bfdd715-45c9-4a5a-b510-9712332c3daf | 716185-lab2-compute.rpc.rackspace.com    | bc86f9ab-924d-4835-9462-d736577da24e | power on    | active             | False       |
| 76330533-9bdb-4e95-902e-1ef702be9420 | 716186-lab2-compute.rpc.rackspace.com    | 519d241c-ff2c-4fda-8007-3c26a85c792a | power on    | active             | False       |
| 46f9dfa8-00c3-43e1-960d-dfa4853de3ea | 716187-lab2-compute.rpc.rackspace.com    | a57aa5a1-518d-49b1-b68e-fc5965f0adac | power on    | active             | False       |
| 0e1a6c50-9add-43c7-a6b7-f30eed30c3db | 716199-lab2-ceph-perf.rpc.rackspace.com  | 17d4f346-8faf-448c-9b93-380e673da191 | power on    | active             | False       |
| 536bf375-2154-4561-bcda-b6fbfb251a22 | 716200-lab2-ceph-perf.rpc.rackspace.com  | 14b4b675-103b-4023-9a39-91263b15830b | power on    | active             | False       |
| 232d56b6-25fd-4e3b-a0b4-97ad48ff3056 | 716201-lab2-ceph-cap.rpc.rackspace.com   | 5ae2d697-6b22-46fc-8053-305da6e94927 | power on    | active             | False       |
| 02da6024-9004-4a36-a37c-0213db7c91da | 716202-lab2-ceph-cap.rpc.rackspace.com   | 38f2c075-c3cd-4438-a160-c3439a8b93bc | power on    | active             | False       |
+--------------------------------------+------------------------------------------+--------------------------------------+-------------+--------------------+-------------+

Comment 2 Gonéri Le Bouder 2016-07-13 11:57:04 UTC
I see a similar error in #1353079.

Comment 3 Gonéri Le Bouder 2016-07-13 12:02:10 UTC

*** This bug has been marked as a duplicate of bug 1353079 ***

Comment 4 Emilien Macchi 2016-07-13 12:06:08 UTC
I moved it to THT as the code of this is in THT.
Regarding your bug, I also found this warnings sometimes when the hieradata was wrong, example with a nil value for a parameter. Can you tell us what environment you're running?

Comment 5 Gonéri Le Bouder 2016-07-13 12:18:32 UTC
Hi Emilien,

Thanks for your feedback. The SSL configuration was outdated like described in https://bugzilla.redhat.com/show_bug.cgi?id=1353079


Note You need to log in before you can comment on or make changes to this bug.